No Bluetooth Connections to MacOS [April 2023]

Hi All, I’m new to the forum and wondered if someone can help me,

I am having connectivity issues with the Zwift Hub, which has been driving me crazy the last few days.

So, straight out of the box and fully assembled, I have updated the firmware versions on both the Hub and MacOS App (I use Zwift on my MacBook Pro)

For some reason, the hub is not discoverable via Bluetooth and is not being listed as a device on my macbook pro to connect to. I cannot connect the hub to Zwift at all.

Bluetooth is switched off on my phone, so there is no other device attempting to connect to the hub.

My macbook pro is running OS 11.7.2 and is BLE supported so I don’t believe my hardware to be an issue.

Strangely, I can download the zwift app for Android, and connect the hub via Bluetooth to use on my phone. But I don’t really want to use zwift on my phone? And this surely can’t be my only option…

I have tried all trouble shooting guidance listed on the " Resolving Mac BLE Pairing Issues After an Update" page, but none have been effective.

If anyone can suggest some other troubleshooting to try, I would most appreciate it!

  • Geoff

Hi @Geoff_Owen welcome to Zwift forums!

Shuji at Zwift HQ here. I scanned through your logs on our server, and it looks like prior to your purchase of a Zwift Hub, you had been using a Tacx with that MacBook Pro, correct?

Step 1: What I’d like to have you do is to use Mac Finder and go to Documents/Zwift folder and look for a file called knowndevices.xml, and delete that file.

Knowndevices.xml is the file that remembers trainers, heart rate monitors, speed sensors, etc that you’ve paired to in the past, and whether you paired to them via Bluetooth (BLE) or ANT+. Next time you log in, you’re starting over with no stored devices.

Step 2: I noticed that you’ve been pairing over ANT+ rather than BLE for some time. I’d like to have you unplug the ANT dongle from the laptop for now and let’s troubleshoot over BLE only.

Step 3: Launch Zwift. When you get to the pairing screen, you should only see the Bluetooth signal because you removed your ANT dongle.

3a: Pair first to the Power signal.
3b: Click Controllable and WAIT ~15 seconds for the signal to start broadcasting. Over BLE, the Controllable signal doesn’t broadcast until Power is paired, and that will take 10 - 15 seconds. This is normal for BLE.
3c: Finally, pair the Cadence signal.
4: If you have a heart rate monitor that broadcasts over BLE - go ahead and pair that too.
5. Pick a world / route and ride. When you save and exit - a fresh knowndevices.xml will be saved to your hard drive.

Please report back and let us know if that got your trainer signal to appear and work correctly? If so - you may not need your ANT dongle if the BLE signal strength is solid.

If you use ANT+ DO NOT mix and match with the BLE signal from the trainer. I see in your log history that this has happened in the past, and that’s not helping you. It’s probably because the Controllable signal starts broadcasting almost instantly over ANT vs. 10 - 15 seconds over BLE.

Hi Shuji - thank you for such a quick response.

You are correct, I was using an old Tacx Satori Smart trainer previously which I pretty much always connected via ANT+.

I have located the ‘knowndevices.xml’ file and deleted this from the folder and recycle bin.

Again, with all other devices with Bluetooth switched off (phone & watch) I have re-attempted to connect the trainer to my MacBook/Zwift app, but unfortunately no success. You can see from the screen shot below that the hub is still ‘undiscoverable’. Also, I have not connected the ANT+ dongle (haven’t done so whilst recently trying to troubleshoot this.)

Is there anything else I can try at this stage?

This icon indicates there is some kind of Bluetooth problem

Screenshot 2023-04-19 at 05.32.08

If you have an iPhone, I would try running the BT Inspector app to see if the trainer is visible there.

Hi Paul, I am on Android - no iPhone unfortunately. I have performed all Bluetooth trouble shooting advice on the “Resolving Mac BLE Pairing Issues After an Update” support page. This involved resetting the bluetooth module and removing all paired devices. Still no joy. :upside_down_face:

I don’t have an Android device so I haven’t tried them, but there are Bluetooth scanners available for Android. Here’s one…

Thanks Paul, my phone has no issue pairing with the Hub, I’ve managed to update the firmware (via companion app) on the hub and pair with the zwift android app. It’s my MacBook Pro which oddly cannot find the hub.

Which model of Mac is it? (See “About This Mac” in the :apple: menu)

Also did you get a pop-up window asking for network access when you installed Zwift on the mac? If not, I would reinstall and hope to see it.

Thanks Paul, details are:

MacBook Pro (13-inch, 2019) - Big Sur 11.7.6 (updated firmware today hoping for fix)
2.4 GHz Quad-Core Intel Core i5
Bluetooth Low Energy Supported: Yes

Interestingly, I downloaded a bluetooth scanner for my macbook and it could see the Zwift Hub, but it couldn’t connect to it? It would attempt to connect but stay at 40% and then fail.

I’m slowly losing my mind now…

Your equipment and OS are of course supported. I have never run Zwift on Big Sur, only Monterey and Ventura. That should not matter but could be something to try if you don’t have a reason to stay on Big Sur.

There is a clean reinstallation process you can follow that involves manually deleting some folders that include some settings and preferences. That might be worth trying. (The docs are out of date in that the “cp” folder is meaningless so don’t worry about that.)

Can you tell me which version of the Hub firmware is installed? I’m assuming the firmware update went smoothly and you’re on version 4.0.1? If yes - your issue is with the game app or macOS side of things.

I second @Paul_Southworth recommendation to perform a complete uninstall / reinstall with the instructions in his link. Reboot that Mac, and launch Zwift as usual. Does it work?

If no: you seem tech-capable so I’m going to ask you try starting Zwift from a command line in Terminal. This site walks you through how.

Specifically- you’re going to look for

Would you try those things and let us know if that fixes it?

Hey Shuji, it’s 4.0.1.

I have updated to Ventura 13.3.1 this afternoon. Uninstalled and re-installed Zwift, with no success.

I updated my post above while you were responding. Please try loading ZwiftAppMetal from a terminal command line.

I have performed the uninstall and clean re-install using the instructions. However, when opening the app for the first time it remembered my login details and auto signed me in? This doesn’t seem right?

In terminal - the command line (with my username) states the file doesn’t exist, but when I manually navigate to the file, it’s there. The only way I could open the app in terminal was via “open -a zwift”. Would this open the specific ‘zwiftappmetal’ file?

woah UPDATE - I manually navigated to the file and dragged the ‘zwiftappmetal’ file into terminal and hit enter. This opened zwift and prompted me to login using my password. It then asked me to allow for bluetooth connection. And now…


Good to hear. Please use this workaround for now.

You’ve run into a bug that’s not exclusive to the Zwift Hub trainer, but does occur for some macOS users. We’re working on it, and appreciate you taking the time to jump through these hoops with us.


@shooj ok, so the moment I close terminal - it closes down zwift. When I re-open the zwiftappmetal file it auto launches terminal and is spitting out code.

When I open the file as i usually would from my applications - I am back to the same issue.

Thanks Shuji, if you’re confident this isn’t the hub trainer then I’ll use this as a workaround. Happy to help if you need assistance with any testing!

1 Like

Hi @shooj just to advise, the Zwift app was working as should on the previous update. Since the recent update (performed yesterday), the problem seems to have reverted back, where bluetooth connectivity is not being recognised. Not sure if you’re aware the problem is back, so thought to let you know…