Wahoo Kickr snap + Mac OS Catalina not working

Hi,

I’m running Zwift on a Macbook Pro with macOS Catalina (10.15.1), connected with a Wahoo Kickr Snap. Unfortunaltely Zwift does find my Kickr Snap and connects, but displays ‘no Signal’, see attachment. However, on my iPhone 11 I am able to pair and receive a signal. So I’m pretty sure this is a Zwift - macOS Catalina data transfer issue. The bluetooth pairing is going ok, but the signal is not send to the Zwift app.

Hope you can help,
Thanks

Allard

I am so annoyed by this bug I want to cancel zwift.

HI Allard,

I just upgraded my Mac operating system to Catalina and am having the exact same issue as you mentioned - i.e) can find the KICKR but can’t seem to get a proper signal. KICKR works fine on the Wahoo Utility app so figure it has to be same issue as you. Did you ever find a remedy?

THanks,

James

Hi,

I just bought a new MacBook Pro and it’s working now. However, it still doesn’t work on my old Macbook Pro from mid 2012. Both laptops are running Catalina and I honestly don’t have any idea why my old laptop doesn’t recognize the kickr snap.

Best

Allard

I’m having the same problems with my Tacx Flux S.
And the support of Zwift is bad, very bad…

I’ve been working on this problem now for 3 weeks - no end in site

Same issue and have tried all recommended resolutions. Tried to contact Zwift support directly, but no one responded. This is super frustrating.