Zwift no longer sees my Wahoo Kickr Snap

I have been using Zwift for 3 years with the same set-up. A Wahoo Kickr Snap connecting to Zwift through Bluetooth. It has been seamless from day one. Suddenly Zwith no longer sees my Kickr Snap. I have made no changes to my set-up. The Snap does connect to the Wahoo app and I was able to perform the spin down recommended in the Zwift Support pages. Has anyone had the same issue that can explain to me haw I can fix this problem in layman’s terms?

What are you using to run Zwift? Direct to AppleTV? The companion app to a device? Directly to a computer?

I’ve sometimes had trouble when switching connection methods (either intentionally or accidentally). The solution has been to shut down/unplug everything and restart.

I am connected via Bluetooth through an iPad. As a test, I downloaded the BKOOL bicycle app today and it connected seamlessly to my Kickr Snap through my iPad and operated perfectly. And it works seamless with the Wahoo app. So everything tells me the problem is with Zwift.

Try this

Thanks, but unfortunately that box is already checked.

Do you have an iPhone? Might be interesting to download Zwift and see if it works that way.

I do have an iPhone and it is already downloaded on it. Always has been. I have never tried to use it on my phone though. I might try to remove it from my phone to see if that works.

I was suggesting you try to run it on your phone - to narrow down the issue to the iPad.

Like I said he BKOOL app worked fine on my iPad so I do not think the iPad is the problem. That being said, I will try to run it on my phone and if it works, block the Bluetooth connection on my phone to see if that has been interfering. This is a suggestion from my local Zwift users group.