wahoo kickr Iphone connection issue

Im having issues connecting my kickr to my iphone. I can see on my phone in the blue tooth settings that its connected to the wahoo but in the zwift app it cant see the Wahoo.

I have just swapped my wahoo Kickr from the version 1 to the latest model and both have had the same issue. so far i’ve checked:-

  1. Iphone zwift app is up to date.

  2. wahoo firmware is up to date

  3. no other apps are running on the phone prior to starting  a session

The only way ive had sucess is by deleting the zwift app & then downloading it again.

I also have trainer road and the connection with this is 100% every time so there seems to be some weakness in the bluetooth connectivity with zwift  

thanks in advance for any help


So the Zwift app is the only thing running when you try to connect the trainer? 

You also might want to disconnect the trainer from Bluetooth in the Settings Menu of your iPhone, this could be causing issues.

I have never used TR, but I am guessing they use BLE in a different way and so I wouldn’t’ compare the 2 when it comes to connecting.


thanks Paul…

yes only the zwift app is running.

its hard not to compare with trainerroad as it just works every time.

also turning kickr off at the wall, turning iphone off, restarting iphone with nothing running and still issues.

i cant be the only one struggling with this. Iphone is 7 plus and bang up to date.

maybe i should just remove the trainer road app incase its just giving connectivity priority to that but if its not on and running in the back ground, shouldn’t make a difference.




If you see your KICKR connected in the Bluetooth settings, it means your KICKR is paired directly with your phone, not Zwift. Zwift’s Bluetooth feature requires your phone to be unpaired in order to connect.

Follow the instructions in our pairing article, and you should be able to connect.

thanks Jason…

unfortunately still not sorted with this. followed what you’ve said and even tried with the ant dongle w/o success.

when i try to pair with a controllable trainer, i cna see the wahoo but when i say ok i only get an option to skip or just watch…the “lets go” doesn’t appear.

the only way i solved this at the weekend was by deleting the app and re downloading it fresh & it worked 1st time. Obviously dont want to have to do that every time i zwift.

I have been using zwift on ios since it launched w/o problems till the last few weeks