Bluetooth pairing not working after macOS Big Sur update [SOLVED]

I am new to Zwift. I had my Wahoo trainer + cadence and heart rate monitor linked via Bluetooth. All worked fine. then one day it was unable to pair up. you could see the Bluetooth icon was searching…but could not find my devices. Then an icon would appear that said i should “wake up my devices”. I tried that but to no avail. I have tried unplugging the trainer and plugging in again, turning Bluetooth off then on again. But same problem. Zwift “support” does not really exist. Any ideas? Thanks.

Hi @Lou_Jaffe, welcome to the forums! Please give us a full detail of your setup, we need more info to help.

1 Like

hi, and thank you for your reply.

I have a Wahoo Kickr Snap A96E wind trainer with the following additional sensor devices: a Wahoo Cadence D609 and a Tickrfit F281 heart rate monitor.

I was able to successfully pair these devices to Zwift via Bluetooth when I started my Free Trial with Zwift. I had a few workouts and all worked well. I was nearing the end (I think) of my free trial, and was then unable to pair the devices. Zwift was searching but could not find the devices, and said I needed to “wake up my devices”, whatever that means.

The attached picture shows an icon near the bluetooth icon with what appears to be a “!” symbol, suggesting there is a problem of some kind. I went into settings but could not find anything to change or adjust.

Lou Jaffe

looks like you are using a mac, make sure you allow Zwift permissions or the bluetooth won’t work. Did you recently run an update of the mac OS?

That is for ANT+, don’t worry about it since you use bluetooth.

2 Likes

I’m having a similar problem with my Tickr and BLE pairing. This started with the Jan 21st update. Pairs up on Logon and then when the event starts drops off. Sometimes it’ll give me 70bpm which about half of the mean HR. Works fine if I use ANT+ but I’d like to use steering with my Wahoo Kickr Bike.

I’m running a Win10 i7-6700 Dell workstation on a wired network with 1GB fiber internet.

Thank much, Mike. Yes, I am using a MAC. I did not recently run an update on the MAC OS. Hate to sound dense, but where do I find “permissions”?

@Lou_Jaffe

Please see this Support Hub article. Apparently updating to OS Big Sur is resetting app permissions to the (restrictive) security settings that prevent Zwift from running correctly.

It happened with Catalina OS, and it seems to be the same for Big Sur.

1 Like

Thank you!! I went thru that drill, but could not locate the Zwift app icon. it is certainly in my Dock…but I did not see it as an option to select when following these instructions.

???

@Lou_Jaffe
Hmmm. Thanks for letting us know that.
Next try resetting your Mac’s Bluetooth module.
Did that solve it?

After that: is a clean uninstall / reinstall.

  1. In Finder, search for “Zwift” and delete all the folders and files that come up
  2. Download from zwift.com/downloads and install that - this has the latest Zwift launcher app.
  3. The Zwift launcher app piggybacks onto your OS’s default browser (Safari). So open Safari, and purge its cache.
  4. Park this new launcher app in the dock, and fire up Zwift using that.
  5. When you’re prompted to allow permissions - say yes to everything.

How about now? Are we there yet? :grin:

I will try the reinstall soon. Thanks.

where do i find permissions?

@Lou_Jaffe
Instructions in the link above
https://support.zwift.com/en_us/zwift-crashing-on-macos-catalina-Skroq_lzv

ok, thanks. Will try soon…

that seems to have worked, thanks!!! Hope it stays connected!!!

Appreciate it…

1 Like

@Lou_Jaffe
We appreciate you taking time to close the loop. Hopefully this thread will help other Mac owners.

Thanks for the workarounds - I have tried them all after having a similar problem, but nothing works… clean install, bluetooth reset, deleting all Zwift files, allowing Zwift full disk access, and so on. There is simply no communication between what I do on the bike and the screen.

Sorry to hear that. I reset Bluetooth on my computer as they suggested and that workers for me. Hope it sticks

Please excuse any typos

@Mark_Deuze

Your avatar not moving in game is probably not related to the Big Sur update if you’ve taken all those steps.

There are a number of causes which are in our Support Hub. Would you try those suggestions?

Thanks for your reply - much appreciated. Indeed, it seems a hardware problem (connecting with Wahoo fitness app works fine, but no power/speed there either)…