Wahoo KICKR reversed gradient [October 2021]

I have the same setup and same issues. Have you figured out a remedy?

Did you roll back the firmware as described?

Tried, but clicking on the wahoo phone app trainer Icon 10 times (or more) did not bring up any options or do anything else. Maybe I misunderstand the process.

Tried again (20+ clicks) and succeeded in rolling back the update. Will try a lumpy course tomorrow. Thanks!

Can you post the steps Wahoo gave you?

Same issue randomly on ATV 4k with Kickr Core. Restarting Kickr and Zwift might solve for the moment but it’s a Nightmare on group rides. Hoping for a solution soon…

Hi Brian,
Here is the final reply from Wahoo. Got the impression they thought it was to do with Bluetooth interference.

The first part is unpairing, shutting everything down and repairing.
The second part is the factory spin down, which I had never done before.
Not entirely convinced the issue is resolved but haven’t had any issues since. Wahoo happy for me to go back to them if the problem reoccurs.

Good luck.

It’s certainly possible that you could be getting bluetooth interference with those devices. I would advise that you shut them all down and then try the re-pair of your KICKR to establish the best connection with your device as per the previous steps:

  1. Un-pair your KICKR from ALL apps and devices to which you’ve connected. This includes but is not limited to phones, tablets, smart TVs, cycling computers, fitness tracking watches, the Wahoo app, Zwift, Training Peaks, etc. Please also ensure that all devices are powered down or have their BT disabled, except for the device on which you are running the Wahoo app.
  2. Forget the KICKR if it is listed under your Bluetooth settings
  3. Toggle Bluetooth off. Please note, this needs to be done from within the Bluetooth menu of the Settings app. Doing this in the Control Center does not fully turn off BT.
  4. Turn off your phone
  5. Reset your KICKR (unplug for 30 seconds - important)
  6. Turn on your phone
  7. Turn on Bluetooth
  8. Open the Wahoo Fitness app
  9. Go to the Sensors page
  10. Choose the option to add your sensor
  11. Make sure the KICKR is awake
  12. Choose the KICKR and save it
  13. Complete a factory spindown
  14. Re-pair to Zwift

To perform a factory spindown
This process is a bit different than the standard spindown process, so be sure to follow the steps below:

iOS (see full instructions) :

  1. Open the iOS Wahoo Fitness App and navigate to the Sensors section
  2. Connect to KICKR from the sensors screen and save , selecting your preferred profiles
  3. Return to home page to select a KICKR-enabled profile and start a workout
  4. Tap the sensor icon in the upper left, then the wrench & hammer :hammer_and_wrench: icon next to the KICKR
  5. Tap the instructions (above “Perform Spindown”) five times - new factory spindown instructions will appear below
  6. Tap Perform Factory Spindown (may require scrolling down on smaller screens) and follow the steps on-screen to complete the factory spindown*

Going forward, you will not need to perform a factory spindown again, but you’ll still need to perform a basic spin down roughly every 2 weeks or whenever the trainer is moved.

*If the resistance is too high to pedal during the warm up period, please skip this part and wait until the spindown process begins. The app will have you perform 2 spindowns in a row. This process should release the brake and the resistance will return to normal. Once complete, perform a second advanced spindown in full (including the warm up period) to ensure the best power accuracy on your KICKR ( additional factory spindowns should only be completed as directed by a Wahoo agent ). Again, going forward, you will only need to complete a basic spin down roughly every 2 weeks or when the trainer is moved.

Sue,
Thank you for taking the time to send this to me! It worked! I’ve only ridden lumpy Central Park, but the gradient changes were correct. This is a better fix than reverting to an earlier firmware update in my opinion. Thanks again!
Brian B.

Very welcome Brian.
Fingers crossed.
Yep, Wahoo don’t want people to revert to earlier Firmware.
Cheers, Sue

a quick comment in case anyone from Zwift or Wahoo reads this:

it seems like the common thread here is that all Kickr users are rolling back to the last firmware before Wahoo “Added: Bluetooth FTMS support”. my hypothesis is something about Bluetooth FTMS doesn’t work properly in Zwift.

here’s what i see:

could be a red herring, but human brains are good at noticing patterns (even when they are due to noise!)

1 Like

Just here to moan…I don’t have a solution. This has been happening more and more lately (Kickr 5, latest AppleTV). Happened this morning so ditched the ride and went to Rouvy : no problem. So for me, it’s a Zwift issue. Hope it gets fixed soon. Moan over.

This started happening to me with the Neokyo update, with the old firmware. I updated to the new firmware.

The problem is not the firmware. I have a 2018 and v5, same issues with the latest firmware or the older firmware.

PLEASE Zwift, don’t make this another Apple Watch issue where you blame everything under the sun BUT your software for 3 years and then you finally admit your implementation was buggy.

It’s really getting frustrating. Running Zwift off a laptop w/Windows 10 via Bluetooth with a Kickr Core. Resistance is all over the place - spinning uphill, working on flats and downhills. Seems to get worse as the ride goes on. At times, it gets so difficult that I have to kill the ride. No problem when using the same setup with Rouvy. Is Zwift offering any kind of refund until they get it straightened out?

1 Like

It’s been two months since Shuji posted that Zwift is working on this issue. Is it still being worked on? Just bought a new KickrV5 and this is the biggest bug I have ever experienced in Zwift, and I’ve been using Zwift since beta. Should I just return the Kickr or will it be fixed soon?

After riding for about an hour the resistance goes out of sync and does not match the gradient in Zwift. Going down Box hill I have to push hard on the little ring, and going up Box hill I’m spinning out on the big ring. Doing races like this is even more annoying than all the 70 year old ZPower users riding steady at 5w/kg.

Using ANT+ is not an option for me because I’m using Apple TV, and I have been using a Tacx Neo with bluetooth for years without any issues.

Why don’t you try to use ANT+ many people report that it is a lot more stable. When you get a usb dongle also get an extension usb cable to get the dongle close to the trainer.

Internal Bluetooth is not very good.

I’ll give that a shot but I have been using that setup for close to a year without issues plus I don’t have problems when using that setup with Rouvy.

Any sign of this being rectified yet?

As an experiment, I tried running Zwift from my Samsung S10E instead of Apple TV 4k. I tried a workout in ERG mode. Things seemed to work ok for about 5 to 10 minutes, but then things went wonky with surging bouts of high resistance, etc., i.e., the usual. I struggle through another 10 minutes before quitting the session. Then, I went back to the Wahoo app and recalibrated my Kickr Core, restarted Zwift and just selected a free ride. I was able to complete the full 16 mile course with no issues.

I plan to try another ride tomorrow using the Samsung S10E to see if it works without the recalibration step. If it does work, then I think it points to Zwift running on Apple TV.

Just an update, was able to run in both erg mode for a workout (at least I think Zwift ran OK, I was beat when I reached some higher power sections near the end of the workout, so I was fighting erg mode) then I did a free ride with virtually no significant issues. These were run from my Galaxy S10E phone instead of Apple 4k TV. Although it was a relief to not fight the wonky resistance issues that I get with Apple TV, running Zwift through the Apple TV is a much nicer method, when it works.

I would also note that my phone is positioned further from my Kickr Core than my Apple 4K TV (which is within 5 ft of the Kickr).

Same here.

Subscribed and installed Zwift two days ago. Running it on Win10 laptop paired via bluetooth to Kickr Core running latest firmware. Experienced the issue just a few minutes ago. Restarted app, did Kickr spindow. Still same issue on the couple of rides I did today. Doesn’t seem to be “reversed gradient” in my case. It seems that resistance is lagging behind course on screen. For instance, just after my avatar rode pass a 15% gradient incline, the huge resistance of the trainer kicks in.

A quick search on google shows this to be a recurring problem. Hello Zwift Support, where are you?