Wahoo KICKR reversed gradient [October 2021]

We’ve received several recent reports from some Wahoo KICKR owners that gradients in free ride mode feel reversed. That is, resistance on a +5% climb is easier than the -5% descent.

We are working on this bug - stay tuned to this thread for updates.

5 Likes

I experienced something similar, just now, but it wasn’t that the gradients felt swapped. I did Tour of Fire and Ice, and the Alpe gradients felt almost cut in half. At the start of the ride, I’d adjusted my Trainer Difficulty setting to max, and I checked it at the end to make sure the adjustment had actually saved - it had. Last ride I did was set at around 60%. Could it be that the app is “remembering” the previous setting and not actually adjusting when the user makes the adjustment?

I have a KICKR w/ Climb, and anyone who’s used a Climb knows how obvious it is when something is “off” with gradients.

Edit to add: Running app v1.17.0 on iPad OS 14.7.1

Time to hit AdZ

4 Likes

Is this not same issue as previously described in other topic? ( [Zwift won’t adjust power and terrain after latest Wahoo KICKR firmware v4.21])

This has been an issue for months and downgrading trainer firmware was the only solution that works.

I am on Kickr V5 connnected to a laptop. I had exactly the same issue, that is to say the change of trainer difficulty during a ride is not taken into account unlike before.
I always do my race WU in 0%TD and then switch to 50% for racing. It did not chnage gradient feel at all.
I did some test after with 100% TD and if you exit/launch the game with this parameter it will remember it but you can’t modify it after during the ride.
thanks Zwift team for fixing this!

You still have to put down the same power, though :wink:

Thanks for the tip! Yet another workaround to add to the checklist of “how to make Zwift as un-glitchy as possible.”

I’ve been directed to this forum by the technical tier of Zwift support after they examined my log files to determine that this wahoo resistance issues is the source of my problems. I’m not experiencing a switch of gradients… instead the problem I’m having is that the custom workout mode will not change the power levels in erg mode. So, there may be multiple problems this issues causes.

I’m on a Wahoo KickR core, BLE via companion App to MacBook. I’ve already tried the downgrade firmware option on the Wahoo and it didn’t work - (and the Wahoo support folks don’t recommend).

This resistance issue means that I’m unable to use Zwift currently as the workout mode is the primary reason I’m a Zwift user. I hope there is an update soon.

I use a kickr core and a few weeks back had a random resistance lag issue…apparently it happens with kickr core version 1.1.1. On another thread it was suggested to uninstall Zwift and reinstall which I did and fingers crossed the problem seems to have resolved.

Hi folks. I’ve had issues with the gradient at 12% but the resistance literally was stopping me from pedalling. Also at times 5% I can be spinning at 11/54 other times. I’m riding up hill spinning at a nice 220 watts and it says I’m doing 8kph. My machine is less than a month old and I’ve reset it a few times, the last few rides have been all over the shop. Also I run an 11-23 with a 54/39 front.

Not sure this is related but on the zwift app my Wahoo Kickr Core the trainer difficulty is set at max and although it’ll slide it automatically returns to max. My beginner legs just can’t take anymore :weary: :slightly_smiling_face:

Hi all,

I’m not sure I have the exact same issue, but thought I’d join in with this thread.

My setup is windows laptop running zwift, wahoo kickr connected via Bluetooth. Laptop connected to TV via hdmi for big screen.

My issue is it feels like I am riding the resistance of the map profile in zwift of what appeared about 10 seconds previously. I have tried downgrading the Wahoo firmware to no avail. I have uninstalled and reinstalled zwift and the companion app to no avail. I have reinstalled a fresh version of Windows to no avail.

I have 2 work arounds which work - if I run zwift and the companion app together and use the companion app to connect the Bluetooth devices, this resolved the problem. This is then dependent on my mobile phone WiFi connection which is inconsistent.

The other is using my phone to run the full version of zwift, which would then use the mobile phone’s Bluetooth and WiFi again. This revolves the problem, but I have to watch on a phone screen rather than the TV on the wall.

I have ordered an ANT+ dongle for the laptop to exclude Bluetooth issues with the laptop. That should be arriving tomorrow hopefully.

Kickr Core and ATV 4K here. Issue as mentioned here where the gradient seems to lag. Workouts sometimes get this offset too so they are impossible to complete. Usually ending the session and starting again fixes the problem (But then your race or group workout are long gone).

Hi @Ludovic_Pollet_X and @Mark_Stocking welcome to Zwift forums
We had a few reports last week of Trainer Difficulty being set to 100% without the user’s input. We’ve identified the cause of that one. You can keep track of that on this thread

We use a Wahoo Kickr Bike and have been riding on Zwift for a couple of years with no problems. Today the resistance is not reversed for us but is less . I road up inclines that I usually have to change gears for. Wife is riding now and reports the same thing.

Exactly the same issue here. Noticed it the other day and then again yesterday. I have a Wahoo kicker. Harder to pedal downhill easier up. V weird. Difficulty set to 100% as per usual.

Hi all,

I tried out ANT+ and this resolved all my issues. If you haven’t tried give it a go. I got a dongle off wiggle and a USB extender to sit it right next to the Wahoo. Good luck.

I have noticed this same problem from time to time but I’m riding a Saris H3. The grade display in the minimal seemed completely inverted for a short time.

I’m running a Kickr 5 with my iPad 6th gen.

My issues have been 2 fold .

  1. when doing free ride the gradient does not match the resistance of the trainer.

  2. Occasionally, when in a workout, there is a significant delay between the start of a new segment and the change in resistance.

Is it possible that the 2 problems are related and that the "reverse resistance"is in fact a delay in resistance perhaps related to a problem in the transmission of Bluetooth signal between the device and the trainer?

Just a thought.

I’m having the same issue…or at least I think I am.

For me it seems to be a combination of lag in resistance, and other times just getting it wrong completely. I was training in ERG mode today, and during the “harder sections” it’s telling me to put out 235W…Couldn’t hit more than 180W despite putting my cadence up from 100 to 140… Then on the “cool down”, target was 145W, to which my cadence was reduced to below 70 and was putting out over 250W - at this point the resistance was really high!

Hopefully they get a fox for this soon, as it’s just no use! I’ll try a couple of the workarounds mentioned on here, but any other suggestions are welcome.

I’m running on Windows 10 with the Zwift Companion app on Android. Don’t think there are any issues with the Bluetooth, as there doesn’t seem to be any drop out in power or cadence.