Wahoo Kickr Core power & cadence freezing on Zwift

Having a strange issue and can’t seem to find any recent posts that cover it.

I get an issue where the power and cadence will freeze or stick at say 170w 85rpm. I can pedal harder or even stop pedalling completely and my avatar will still be riding until I bring up the pairing screen and unpair it. The pairing screen can still show it’s producing watts even though I’ve stopped pedalling.

Have to either power down the Kickr or unpair and wait then repair it again.

Kickr has latest firmware, recent spindown been carried out, it’s paired on FEC option for ANT+ for pairing screen.

Have reinstalled Zwift to see if that helps, and if happens again will try unplugging ANT dongle to see if can narrow it down to a Zwift or Kickr issue but it only seems to happen after riding maybe 45 mins to an hour so it’s hard to replicate it.

Does this sound familiar to anyone else?

Hi @Troy_Little

Sorry to hear that your KICKR’s power and cadence is freezing in Zwift. I can’t say I’ve heard of that before, but if I had to guess it sounds like either a hardware fault with the KICKR or an issue with your ANT+ dongle.

You mentioned about unplugging the ANT+ dongle, and I assume you mean to try using Bluetooth LE (BLE) to pair instead. That’s a good idea because that’ll let you know whether the issue is happening with only ANT+ pairing or if it happens regardless of pairing method.

You can also send our team a support request if you’d like, and we’re happy to take a look at your log files to see what’s going on there. You can reach us here.

Hi Steven,

Last nights Zwift session worked ok so I’ll see if the problem comes up again now.

Plan was that if the power & cadence froze again I’d try unplugging the ANT dongle - if output drops then it’s coming from the Kickr, but if it stays stuck then would be something going on with Zwift. Or I could try the Wahoo app and see if the Kickr shows output there with no pedalling. Will have to see if the problem comes up again first.

Not tried pairing with BLE yet, think I had some issues getting that to work on my laptop but I can look again maybe.

Thanks for responding to my post, if problem comes up again I can look at getting the logs and sending them for analysis :+1:

1 Like