Wahoo Kickr & Climb out of sync with Zwift course gradient changes

Hi,

I am using a 2018 Wahoo Kickr with Climb and headwind connected via Bluetooth to ipad.

I also use the Zwift companion app via Samsung S20 5G.

Recently the Kickr and climb have started being out of sync when reacting to gradient changes on the Zwift course.
Example I reach a gradient incline of say 8% followed immediately by a descent of 8% and the kickr + climb will not react to the incline until I am on the descent!

I tried to do the Etape Stage one but as I got to the top of the climb (before the radio tower), on the few descents before the KOM banner it felt as if I was riding up a 10% incline!

Has anyone else experienced this?

I did email both Zwift & Wahoo support but all the checks they have suggested have not resolved the issue.

Thanks in advance.

ATV4k + Tacx Neo 2T Rode the Richmond WC course yesterday, and during the Cobbled Climbs sector my system was not at all in sync with the displayed slope. Actually I did the entire WC route, then went back and did the Cobbled Climbs sector separately immediately afterward—the system was out of sync on both occasions.

Hi,

Thanks for the reply. I re-synched the kickr to Zwift via Bluetooth. Did an activity this morning and all seems OK. Kickrband climb reacted in time to gradient changes on Zwift course (Richmond).

Thanks for your help.

Ben

I am not using the Climb but have the terrain out of sync problem with my kickr core off and on. It’s frustrating as you can’t really tell its happening until the first hill and seems to get worse with time (i.e the delay between the start of a hill and the increased effort increases). Especially frustrating when doing a group ride. This sure seems like a bug. I have had the effort lag the terrain by several minutes.

I’ve been having this issue lately as well. First 10-15 min of the ride there is no resistance change and then it all of a sudden starts to work. Using a Kickr + Climb + Apple TV with companion app. I’ve tried spindowns and ensured all firmware and apps are updated

I’m having the same out of sync issue. It worked perfect the first time I used it and hasn’t been right since. I pair the climber to my kickr before every ride. It makes no difference. It seems to go up or down randomly and never in sync with the course

Pairing hasn’t helped me

What do you mean by ‘resynced’? What’s the procedure for this?

I’ve had this issue a few times. Worst time was climbing ven top. Also had on Alpe Du Zwift. Really annoying. I was still at 10% half way down the descent. Seems to sort it self out when We start a fresh ride.

I am having the same issue all of a sudden. Is there a fix for this?

I have tried several options. First I updated the firmware for the kickr. It worked fine for one ride. I have to calibrate every time now before a ride. Even the calibration doesn’t fix the issue every time. Yesterday I had to result to not using Apple TV and have to Zwift using just my iPhone. The Kickr wasn’t responding to the gradient at all using Apple TV. Using my phone responded perfectly, with no issues, so the Kickr is working fine. I tried moving the Apple TV box closer to the Kickr, still no better. I am thinking of changing over to Zwifting using my Macbook and using the USB to ANT+ connection. I’m reluctant to do this because when the Apple TV box works, it’s so easy to use and the graphics are top-notch. This issue has become worse since all of the current updates. Zwift needs to look into this, or Wahoo does. Is anyone else is having issues with gradient lag? I’m not talking about a couple of seconds. I have climbed Alpe Du Zwift in the past and was still climbing at what felt like 11% when I had fully descended the mountain. The descent can take nearly five minutes. This issue is so annoying and has stopped me from joining group rides. until I get this problem sorted. One other option is to ensure that the iPhone using the companion app and the Apple TV box are both connected to the internet connection. Mine always are, so not sure this is a solution. I’d be gratetful for any help from others with this issue.