Wahoo Kickr Climb “Lag” or Delays in %Grade Variations

Hi there,

I emailed you about this, and you said to post on the forum to try to fix this.

In short, when riding the Kickr Climb “lags” on inclines - in that it might go as follows:

Imagine a route with varying incline over say 300m:
50m : 0% - No Climb Variance
100m : 1% - No Climb Variance
150m : 0% - No Climb Variance
200m : 2% - No Climb Variance
250m : 7% - No Climb Variance
300m : 10% - A sudden lurch to 7% or 10%, with no previous variation over the first 0-250m. My ride will suddenly jump about, which is a less than awesome experience.

  • Current Firmware on both the Wahoo Kickr & the Climb are up to date
  • iOS iPad Pro - again up to date firmware
  • App is up to date
  • I have performed a spin down calibration
  • the accuracy / effort of the Wahoo climb is set to MAX (Ie. It is hardest effort, so therefore should react to all Zwift variances)

Zwift’ s feedback has been:
In regards to your Kickr Climb, you have stated that you have tried updating your firmware, but I’d like to ensure that you have tried to calibrate it.

[1] After updating your trainer’s firmware it’s important to calibrate it as well. Instructions can be found in our knowledge base article “Configuring a Wahoo Trainer​.”

[2] If you have, and you’re receiving readings that don’t quite add up, it may be due to some signal interference. You can check for potential causes here in this article​.

I have done [1] and [2] seems really weird. The Wahoo / Screen set up is immediately next to each other, in that the iPad Pro is literally in front of the bike, less that 2m from the rear of the bike (where the Kickr is - obviously). There’s nothing else electrical in the immediate vicinity apart from an Android phone running the Zwift companion app.

Anyone got any experience with this / similar issues before I start going deleting caches et al. I’m pretty underwhelmed given that Kickr & Climb are supposed to be plug & play integrations.

OK.

I am still getting this issue. I’ll be honest, and say it’s pretty poor. I’ve done yet another ride today where it has repeatedly bucked about completely out of sync with the ride, and I’m not really enjoying the experience.

I have lodged another support ticket overnight, and the response has been:

First, I’d like you to update the firmware on your trainer to see if this helps with your resistance (or lack of) in Zwift. You can do this with the Wahoo app on Android or the Wahoo Fitness app on iOS. Wahoo provides instructions on their site for Android here​ and iOS here​.
After updating your trainer’s firmware it’s important to calibrate it as well. Instructions can be found in our knowledge base article “Configuring a Wahoo Trainer​.”

I am quite sure that the person responding didn’t read either the previous ticket, or the email here, as they are responding talking about resistance - not elevation.

All of the above have been done previously, and again now, and the issue persists & I still have no response to the query lodged on this forum per the instruction from my ticket 3 weeks ago.

So my ride last night which was with no updates, no changes, no different equipment, the Kickr Climb worked perfectly, with no lags, nor delays in shifting between elevations.

The race was the ZHR Hare & Hounds Race © on the 29/7.

As I have said in my previous messages, this is an intermittent problem. The only thing at this stage that I can identify is that the NUMBER of participants in a ride appear to be the consistent factor - when there are more participants it appears more likely that I will encounter issues. Last night was fewer riders, and I didn’t have a problem.

Not getting any love in any of your posts, I see :frowning_face:

No idea if this will be of any assistance, but if the issue occurs specifically when the number of participants is high (and you said in another thread that it began with the L’Etape stages—where the participant count was definitely high), are you sure it isn’t the iPad lagging under the increased burden of rendering everything on screen (and as a result also lagging in terms of sending incline data to your Kickr, to which the Climb is paired)?

Thanks @xavier_nihilo Nope - nothing.

Am completely underwhelmed - no response to my email support requests, no response to the Chat feature offering support, no response on here. Just complete silence from Zwift. Am really disappointed having spend such a large amount of money on equipment that they endorse, and state that they support.

Regarding the ipad - if it is, I don’t fathom why that is the case - it is a 12.9 inch 3rd Generation iPad Pro with 512GB - it’s the “top of the range” iPad running the latest firmware. I also closed all other apps on the device and rebooted it for good measure after the first ride/app/game crash in the Lamb Chop races the other week. My expectations are that if this is a feature that Zwift support, that this is one of if not “the” most accessible device that users would adopt to use with the App - given that the “companion” app is for the Android or iPhone?

Have you tried contacting wahoo?

@PrimalSteve No, I haven’t as the Climb had worked fine with KinoMap previously & with Zwift originally and, it sometimes works fine in Zwift.

I will however log a ticket and include any suggestions from Wahoo in this - I just am aware that it is a “it’s a trigger/signal issue” rather than a hardware issue due to the fact that SOME of the time, it’s fine in Zwift - other times it isn’t. In my view it lends itself to Zwift not Wahoo - but, it is worth me getting their view.

At 3/8/20

  • Still Zero response from Zwift. Have re-emailed this morning.

  • Acknowledgement from Wahoo, but asked if it were only happening in Zwift immediately. Which is hard to answer as it is intermittent, and due to the fact that I only now how a Zwift subscription.