Elevation/resistance discrepancies

Zwift regularly sends the wrong elevetaion data to my Wahoo Kickr - I am using an Apple TV and the resistance does not match the incline shown on screen. I can spin out in max gear on a 10% incline or have to stand on the pedals on a flat. I’ve tried everything the forums have suggested. Sometimes it works for half a ride, other times it will work for the whole ride then go off. Sometimes it’s off from the start.

This is my second time posting this same issue. I tried uninstalling and reinstalling Zwift and it worked for 2 rides. Not it’s acting up again. I’m going a little crazy after spending an awful lot of money on this setup. Any help would be amazing. TIA

I have a kickr and only rarely get this issue and I now just re-pair during the event (usually a group ride or workout so no drama for me) and I’m good to go for several more months - though it would drive me crazy too if I had your experiences.

I have seen quite a few Kickr related issues mentioned here (seems mostly Core related) and elsewhere with these symptoms so maybe the best course is to raise a support ticket with Zwift and include your log file and any other evidence so they can diagnose.

The other thing you could try is either running it on the Wahoo app or even an opposition software when you are experiencing the issue to see if the problems follow the apps.