Wahoo heart rate

Hey - zwift all of a sudden stopped reading my heart rate data. My wahoo tickr would connect but show 0 and then sometimes saying connection failure. I’ve bought a new heart rate monitor as it was old but after one successful ride with heart rate data the same issue has occurred…. I use Apple TV to run zwift. I am going to try and delete the app and restore it but any other tips welcome…

Did you get another Wahoo Tickr? All the people I know with tickrs have tons of issues with them and they always fail.

1 Like

Yeah I did - my previous one had worked for 30,000kms so I figured I was on solid ground!

My own Tickr has also worked for several years with no issues other than battery replacement.

I had one for a few years and first strap I had started going wonky after a few months and was replaced due to high HR reading, it went to 210 and stayed there for 5 minutes, then that one went after 10 months and got replaced, had a new unit as the pins had corroded, then that died from a firmware update failure so had another new unit sent out that was working fine for months until last month then the thing was reading around 120bpm despite hard efforts, changed to a new strap still the same, goes to show how users experience can vary with manufacturers

have moved over to a coospo strap now and so far been working perfectly fine

Hi @Simon_Porter, Welcome to the Zwift Forums.
Fernanda here, part of the support team at Zwift.

I’m sorry to read that the Tickrs is not broadcasting information to Zwift, even though you paired successfully. Can I kindly ask you to please check in your iOs running the Zwift Companion if the “Health” app is ON, if it is running in the background can steal the signal of the Heart rate monitor and affect to broadcast the information to Zwift.

Removed the “health” app’s permission to use the Wahoo heart monitor, and tried to use it once more with Zwift.

Give a try to this information and let us know how it goes!