Vibration on Zwift Hub

Hi,

Has anyone else had issues with this? I have had a Zwift Hub for a year and it has a vibration that seems to come up through the pedals and into the frame of whichever bike is on it.

Under load at higher watts it’s a drumming vibration and at high flywheel speeds, you can feel a vibration through the bike, when you stop pedalling.

To ensure it’s not the bike I have replaced - BB, outer chain ring, chain and jockey wheels. Tried 2 different bikes and swapped cassettes!!

For the record, Zwift Support are useless. Like robots, scripted waffle telling me how ‘worrisome it must be’. Days go by before another person emails back saying they are going to escalate it…

It’s been going on for months…. Any ideas??

Cheers

hi Dan

I have the same problem. did you fixe yours

Hi, Nicholaj,

No, it was never resolved. They eventually sent another HUB, which broke within 2 weeks. It also had a vibration when pedalling harder, under load and there was a rubbing sound coming from within the unit. That one went back and now i have a Wahoo Kicker Core. I don’t think that Zwift sell the original HUB any more. They seem to have a partnership with Wahoo. Good luck with getting yours sorted.

The Hub One is exactly the same trainer as the one they sold previously, it just has a single-cog cassette and an electric shifter gizmo. Since they have the renewed partnership with Wahoo, I would recommend that anyone experiencing problems like this contact Zwift support and ask for either a replacement Hub or a Kickr Core.