Unable to load FIT file to Garmin


(Carl Nolan) #1

Today, after my ride, I was trying to upload the FIT file to Garmin Connect and unfortunately Garmin kept complaining. All you get is a silly red X with the word undefined

Has anyone else come across this issue. This is the first time I have had the issue. Even more annoyingly the file uploads to Strava.


(Eric Oshlo) #2

Garmin Connect can be quite persnickety, so it’s probably an isolated case of minor corruption.  If it uploaded to Strava, you could export it from Strava as a .tcx file and try uploading that to GC.


(Carl Nolan) #3

Strava only allows you to export as a GPX and in doing so you lose most of the performance data.


(Eric Oshlo) #4

Carl, actually you can export a .tcx file from Strava. It’s a little known feature. Here’s a tutorial from the Strava site. Give this a try.

"Strava allows you to export .TCX versions of your own activities.  This is a little-known trick, however it’s simple to use.  Simply add “/export_tcx” - without quotes - to the end of your activity page URL.  

For example, if your activity page is  www.strava.com/activities/1234567890 - just add the text to give you   www.strava.com/activities/1234567890/export_tcx and hit enter.  This will download a TCX version of your file to the location specified by your browser’s preferences."


(Carl Nolan) #5

Cool, thanks for that. The export had some massively inaccurate summary data (had me riding for 2 minutes ay 17,000 mph) but was able to edit the TCX file to get this all correct; even though the Strava summary data is accurate.


(Michael J) #6

This looks like the most recent post on the topic.  This just happened to me as well from a Zwift session last night.  Very frustrating.  I can bring over the TCX file but it has issues as well.  The online .FIT repair tool does not work either.  I’m going to play with it some more but wondering if anyone else has a solution or ran across this recently. 


(Samuel Ritter) #7

this has happened to me for both of my last rides.


(Gerrie Delport) #8

Hi Sam, 

Garmin connect have some issues with some files, why i don’t know.

What i do know is how to fix it.It does not happen often.

I use www.fitfiletools.com the section remover on the .fit file from my Zwift folder, i don’t remove any section I just let it save a new file and then upload the new file to GC.

 


(Andy MacDonald) #9

I have the same issue, looks like a common problem today… Tried the gpx file from strava, fit file from zwift and fitfiletools recommendation all with the same result, any ideas?