Unable to link companion app to my laptop

hello fellow zwifters, please can anybody help…
I’m having trouble linking my companion app on my phone to my laptop…
Ive tried uninstalling both zwift and the comp app, re installed both, checked that they are both on the same network and passwords match,
still no joy…
any help or advise would be greatly appreciated.

Hi @tommy_thompson, this should be the key to success, both the laptop and the phone need to be on the same wifi network. Double check that they are both using the same network connection, make sure your phone isn’t using 5G data or something like that.


Hi, I’ve checked and they are both on the same network… That’s not the problem… :weary:… same network, same password, both running the latest versions… It’s baffled me…:thinking:

Do you have another device running the companion app?

Not sure if this applies to you, but there is a problem with some iPhones and Companion connectivity. Seems to be mostly iPhone 14 but not exclusively.

hi everyone, thankyou to you all for taking the time to reply to me… I have had some help from zwift support… and the problem is now fixed…
I unpaired my tacx trainer and rebooted them, removed my garmin express from the ant+ dongle as it was blocking the bluetooth I think, and now i can use companion app again… i appreciate your help… hopefully i might see some of you on a ride… ride on thumbs up and thanks a lot… tommy