Trouble with jumping WATTS

Good afternoon;

I have a problem with the watt measurement.

My roller is an Elite Qubo Fluid RED and I use Garmin ANT + speed and cadence sensors connected to an Android tablet.

The problem is that the watt measurement (Zpower) gives me jumping data.

The watts go from 60 to 98, from 98 to 152, from 152 to 252, without intermediate values ​​and it is very difficult to do reliable workouts, because I cannot get more or less reliable wattage data.

Do you know why it can be?

Thanks for your help

I have the same problem. My Elite Qubo Smart B+ has worked perfectly for a few weeks, just connected to my Mac through Bluetooth. I just started my first Zwift Workout yesterday, which seemed to go ok.

I logged on to do the 2nd session today and my power kept jumping all over the place - similar variations to yours, changing every second. And the cadence jumps all over the place. I tried on a normal ride instead and it’s exactly the same, both jumping every second, sometimes hugely up and down, and it didn’t seem to react to inclines in the same way.

Any help would be much appreciated!