Treadmill Smart Speed App - "Connection Failure"

I would appreciate help with a “Connection Failure” issue.

AppleTV with iPhone 7 and Treadmill Smart Speed app for Run Speed and this set up has been working flawlessly for about the past 6 months.

I haven’t made any changes that I’m aware of but for the past few days I have a “Connection Failure” issue.

I did go from a paid subscription to free (I’m just running now on Zwift) on April 15 but it still worked fine April 15-20.

On the Paired Devices Screen, my iPhone is showing as connected as my Run Speed. I’m not 100% sure if this is new/different or I just haven’t noticed it before but the Bluetooth logo is doing that circular pulsing thing.

I click on OK and it takes me to the World Choice, Run Type, Device Status, Join Your Friend, Run screen. Of note, the Device Status lists my iPhone as Run Speed.

When I click on Run, it takes me to the Route I selected and I’m all set to starting running. When I use the Treadmill Smart Speed app to select my speed, nothing happens. No speed, distance, time, etc displays and my avatar doesn’t run. Then after about 10 seconds I get the
“Connection Failure” message in the top left hand corner of this screen. I’ve tried to wait for various lengths of time to see if it eventually connects but it doesn’t.

Internet - No issues with any other devices and tried unplug/replug modem

Apple TV - No issues with any other apps and I also tried unplug/replug

Zwift App - Deleted and uploaded a few different times. Confirmed Bluetooth access. Currently not using my smart trainer so it isn’t plugged in or connected

iPhone - Don’t use this phone much so minimal apps, no ZC app, etc. Checked and played around with Bluetooth settings

Treadmill Smart Speed App - It’s a very basic app but I played with it, restored settings to default and confirmed Bluetooth. Also tried downloading the app to a second phone but still having the same issue with different phone/different app

I’m pretty tech challenged and would appreciate any help. Thanks!

I’m not familiar with that specific app, but I have used a similar speed transmitter app on Android that had a tendency to be a bit temperamental at times at throw this same message. When I was encountering this with the app I used to use I would often have to completely reboot the device that is running the app, then open the pairing screen on Zwift to repair and make sure that the app was transmitting a speed before I closed the pairing screen.

Lucas, I’ve tried both of your suggestions without any luck.

I seem to have stumbled across a work around. I’m still using AppleTV. I wasn’t previously using the ZC app. I now have the ZC app on one phone and connect it first. On a second phone I have the Treadmill Speed Sensor app and connect it second. As I mentioned I’m pretty tech challenged and have no idea how or why but this is working for me.

Thanks for taking the time to help me out.

You’re welcome. My first thought for why this workaround is working would be because the ZC app used WiFi to communicate with the Apple TV instead of Bluetooth which is working better in your particular wireless environment so you’re probably getting a better connection.

If it’s working then it may not be worth trying to get it to work without the second phone, but the most common fixes for bad connection are to improve line of sight between the devices, reduce the distance between them, and try to get them further away from other electronics.