Training peaks is not linking

Since the update last week TrainingPeaks is not sending workouts to Zwift although is saving to training peaks. I have not done anything different and have been using the link for. Several years now so can only think it’s the update causing issues.

You’re the first to mention it AFAIK which makes it a little unlikely that this is a widespread issue, though not impossible I suppose. Usually when the integration breaks there is a steady flow of complaints (eg, every time the clocks change). Have you tried removing the connection and adding it back? Is the workout based on %FTP?

Yes I’ve tried unlinking and relinking. Yes you are right if I’m the only one must be something occurred at my end. I will also remove Zwift and reload it that may put it right too. I will let you know. The workouts are based on both power related to FPT and cadence.

I tried disconnecting again and reconnecting plus removing and reinstalling Zwift. The training peaks workout doesn’t appear for selection either in the all workout screen, which it had been doing or if I look for it in the plans and workout screen where the heading is usually found.

Hi

I am not the only person experiencing this another in my training group is having the problem too. She has noted you have said heart rate based workouts won’t now transfer however ours have power, cadence and heart rate within them. Does that mean the heart rate element will need to be removed? To note this us never been an issue before.

My understanding is that TrainingPeaks workouts that include heart rate cannot be imported (I haven’t tested this). I’d retry with the HR element removed, or add some other workout with no HR element and see if it works.

From this document:

Ok I’ll have a go. It seems strange as it never been an issue previously.

I just tried it and my power based workouts synced to Zwift (although it looks like they moved the location to find the workout since I last used one). If I edited the workout to a heart rate based one it did not sync. A workout though in Training Peaks can only be set to power or heart rate based, it can’t be both. When you look at it in TP are the units set to %FTP like in this screenshot?

Screenshot 2024-05-06 at 3.05.58 PM

Another thing that has affected workout syncing in the past is any strange characters in the workout title, so if you still have any problems with it, try changing the title to something with only alphanumeric characters and see if that helps.

Ok. I removed a forward slash / from the workout title and it appeared in Zwift. Thankyou for the tip. Seems to have worked.

1 Like