TrainingPeaks workout syncing issues


The issue appeared 2 or 3 weeks ago.
From time to time, my TrainingPeaks workout won’t appear in Zwift.

I’ve reached out to support who told me there was no known issue, and instead of investigating told me to disconnect and reconnect TP from Zwift. Which I did.

Guess what, yesterday I had the issue again. Which, on one hand, is good, I went and gave another go at Rouvy.

I’m part of a team of coached triathletes, and I’m, not the only one facing the issue in our team. So, this isn’t specific to my environment.

Who else is having trouble? And have you managed to sort it out? If so, how?

Thanks a lot.

I think I’ve managed to figure out why some TrainingPeaks workouts don’t make it into Zwift.
It appears that if you export manually a workout from TP, you have different options (.fit, .erg, …).
If you only have a .fit option as an export, it looks like it won’t make it into Zwift.
My understanding is that .fit workout focus on HR training, and that’s probably why it doesn’t sync with Zwift.

Right! I had the same issue and I couldn’t figure out why TP and Swift doesn’t not sync…

And you figure it out, Zwift can not understands HR based trainings with .fit files.
I have made some Power Based training into TP, restarted Zwift and now it sync without issues.

Solution: Create trainings based on POWER, not HR.

Hi Guys- my TP’splanned workouts aren’t showing as they usually do. Have tried all the usual fixes- diconnecting/reconnecting to TP’s via the Comp App (on IOS and Mac), have reinstalled Zwift and ZC, but still not showing as they usually do? Does anyone have a fix or the same issue? TIA.

Check that your TP trainings are in % of Threshold Power (when you edit / build a training).

Should fix it. At least it fixed mine.

Thanks @Pierre-Yves_Guiot yes that’s the issue, sorted now.