Not able to manually download my workout fro; TP

Zwift is not syncing my workouts from Training Peaks automatically.

I manually downloaded one 3 weeks ago but now can’t as the ZWO file is no longer there.

I contacted support but no answer.

Does anyone have any ideas?

I’m using a Windows based laptop.


Not sure exactly what you mean by downloaded it. If you’ve connected TrainingPeaks and Zwift then your workout will show up in Zwift under a TrainingPeaks folder. Your workout only syncs for that day. So if you don’t have a workout set in TrainingPeaks for that day nothing will show in Zwift.

Are you saying you had a workout setup in TrainingPeaks and it didn’t show up in Zwift?

I am yes.
The workout isn’t there even though it should be today.

For many in my team, auto sync isn’t working and so tried to manually download from Training Peaks but the ZWO option isn’t there either.

1 Like

In the past when this has happened disconnecting the sync between Zwift & TrainingPeaks then enabling it again has fixed this. Worth a shot

Thanks for that.
I tried twice this morning and still not, so have messaged both Zwift and TP support.

Hi Neil.
I’ve gone through similar syncing problems in the past, I’ll share my insights.
Assuming we are talking about bike workouts:

  • Make sure that your workout is “Power & Duration” based and NOT heartrate or distance based, heartrate or distance based workouts will not showup. This one tripped me off for a long time.

  • As D_Watson mentioned, disconnect and reconnect accounts, revoke permission from both “TP/manage connection” and “ZWIFT/Connections”. (I know you already did this)

  • Zwift will only sync workouts on a daily basis (the current day).

If more people in your team experience the same issue, I’m inclined to say that the workouts being synced are not compatible somehow, probably not “power & duration” based. Let us know if that is the case.