Trainer not reacting to road grade


(Greg Billy) #1

Since the last update, my Wahoo Kickr does not respond to changes in the grade of the road.  The displayed speed goes up and down as expected but the resistance feels the same (and consistently more difficult than before the update).  I’ve updated the Wahoo Kickr firmware and performed a spin down but it didn’t help.  Anyone else having this problem?


(Stuart Sutherland) #2

This happened to me last night and I assumed it was because I used the ios on my ipad for the first time. Planned on using my PC again tonight as I couldn’t see anyone else having this issue.


(Greg Billy) #3

I tried reinstalling the Mobile Link app and the Zwift program.  The problem continues.  The Wahoo Fitness app controls the Kickr resistance just fine, so it appears to be an issue with Zwift communicating with the Kickr.


(Greg Billy) #4

Okay, I figured it out.  For some reason, after the last update, Zwift no longer had my Kickr connected as a “controllable trainer” but, instead, only saw it as a power meter.  I unpaired it as a power meter and paired it as a controllable trainer.  Now it works fine.  Thankfully, a simple solution!


(Jon Moss) #5

@greg

I’m having the same issue with my partner’s Snap. Pairing to MacBook Air via ANT+

We don’t seem to be able to pair just as a controllable trainer - to progress past the pairing screen we need to pair as a power meter!

How do you get past this? Any tips appreciated!

Best wishes,

Jon


(Greg Billy) #6

In my case, after launching Zwift and getting to the equipment connection screen, I unpaired the power meter and then hit “search” for the controllable trainer. Zwift found the Kickr which I selected and hit “Okay” to connect it. In the start up panels, it shows up as being connected both as a controllable trainer and as a power meter. When it wasn’t working properly, it showed only that it was connected as a power meter and the controllable trainer block was grayed out (indicating that nothing was connected). I am using bluetooth to connect the trainer to my Android phone and laptop computer. I find it necessary to launch the Zwift mobile link app first prior to launching Zwift on my computer. Also, I have a wifi network extender in my house and find that my phone and computer both need to be on the extension part of the network (i.e. both connected to the same network). Elsewhere I have read that running the Wahoo app at the same time can cause Zwift to malfunction but I haven’t tested this myself. Hope this helps. Good luck!


(Jon Moss) #7

Thanks Greg - appreciate the detailed info!


(Mihnea Dumitrescu) #8

Still not working, after pairing Kickr (the FE-C version on ANT) both as a power source and a controllable trainer.

And the custom workouts do not recognize the ERG mode.

Thanks, Zwift, for ruining two days of my workouts now.  I am so sick and tired of f-ing around with their settings.

Can somebody at Zwift tell us how to fix this?


(Mihnea Dumitrescu) #9

And the spin down on Zwift does not work either


(Mihnea Dumitrescu) #10

Although it seems to work on Bluetooth…


(Jason K) #11

@Mihnea: I saw you submitted a support ticket, so we’ll work with you further there.

For anyone else experiencing issues, I’d start by checking to make sure you’re paired correctly and that your trainer difficulty isn’t all the way to the left. There are also a couple known issues we’re working on: