Tickr-X/Bluetooth/ZML


(Jim Mattson) #1

I run Zwift on a Windows PC, so I use the app formerly known as ZML on my iPhone to provide Bluetooth connectivity for my sensors. (Don’t get me started on the lack of native Bluetooth support on Windows.)

Lately, I’ve found that Zwift often doesn’t see the Tickr-X, even though my iPhone shows it as a connected Bluetooth device. I’ve killed all of the other apps on the iPhone and turned the iPhone’s Bluetooth off and on again, to no avail. The iPhone always reports the Tickr-X as a connected Bluetooth device, but Zwift refuses to acknowledge its presence.

It seems that this started happening around the time of the last Zwift update, but I can’t say for certain.


(Paul Allen) #2

You need to make sure it does not connect to your phone in any way, it should only connect to the ZCA to bridge the signal to the PC. A better option would be to just get an ANT+ dongle and a USB extensions since the Tickr-X is duel-band.


(Steven D) #3

Hi Jim,

There are a few general reasons we’ve seen for why BLE devices like your Tickr X won’t connect with Zwift and a few that are specific to the kind of mobile device you have:

General Issues

  1. Your sensor is paired to a different device. Make sure the phone, other apps, service, or devices aren’t connected to the sensor/trainer. The safe way to do this is close everything other than the Zwift Companion app that accesses BLE.

  2. You have too many BLE devices connected to your phone. Try unpairing any BLE devices (e.g. headphones, speakers) that you aren’t using for Zwift. If doing this lets you pair your devices in Zwift, try adding them back in one at a time to determine how many devices you can pair/what device is causing problems.

  iOS Specific Issues  

  • Make sure BLE is turned on in Zwift Companion app. Settings > Sensors. 
  • Make sure BLE is turned on in your iOS device settings. If your setup matches everything I’ve described above, here’s some further troubleshooting steps that will help me figure out where the problem is:
  1. Turn on Airplane mode, then turn on WiFi and BLE.

  2. On the Zwift pairing screen in game, look at your BLE phone icon in the top-left and tell me what you see and/or send a screenshot:

  • Dimly lit phone: This shows you haven’t paired your phone. Make sure your phone and computer are on the same WiFi. 
  • White icon w/hazard symbol: Your phone is paired, but BLE is blocked. Turn on BLE in your phone settings. 
  • Pulsating phone icon: BLE is on and should be working. Note that most BLE enabled trainers and peripherals have indicators to show if they’re broadcasting/already paired. If all these steps don’t work, research your specific device to confirm that it’s broadcasting/accepting connections.

Give those a try and if that doesn’t help, please submit a support ticket and one of our Zwift support team members will be happy to further assist you. 


(Jim Mattson) #4

I thought that might be the issue, but how do I convince the Tickr-X not to connect to my iPhone? There’s no “forget device” that I can find.

As for ANT+, I’ve tried it, and it is definitely not  the better option, because it frequently drops data. I’ve tried running a USB extension cable close to my bike. With the ANT+ transceiver under the bottom bracket, on the front wheel, or on the stem, ANT+ always has frequent data transmission dropouts. The trial-and-error approach to finding a good placement for the ANT+ transceiver is a nightmare! I even bought a second ANT+ transceiver, thinking the first one must be a lemon. I have the same problem with both of them. I’ve tried front and back USB ports on the PC…no difference. In my basement, with my setup, ANT+ just doesn’t work reliably at all. Bluetooth, on the other hand, never drops data.


(Jim Mattson) #5

Actually, the Tickr-X does connect to the iPhone. Here’s what the Bluetooth screen looks like when everything is working properly:


(Jim Mattson) #6

Sorry about yesterday’s ANT+ rant. I’ve just been very frustrated in my attempts to gat ANT+ to work.

What I really want is for my sensors to just work, each and every ride, without having to fuss with them. That’s all.


(Jim Mattson) #7

Got it, I think.  Despite being force-quit, the Wahoo app seems to be monopolizing the Tickr-X. The calories burned notifications from the Wahoo app should have been a giveaway. Apparently, it’s possible for an app to run an unkillable background process on iOS?

Anyway, I told the Wahoo app to forget the Tickr-X, and I’ve had no issues for two days. Knock on wood.

Strange, though, that the Wahoo app is also connected to my Kickr and my Stages power meter, and I’ve never had problems with those.


(Vincent W.) #8

Glad Zwift is working for your Tickr-X finally! Yeah it’s best to have absolutely nothing paired with your Trainer except for Zwift. There’s a chance your trainer will work if it’s paired to another device, but it’s an outlier and not the best option.