Issue with Wahoo Tickr X on Galaxy S10


I’m having issues connecting the Tickr X to Zwift.
Sometimes it shows up as it should in sensors. But when I start running, the connection drops pretty quickly. Sometimes it starts working again after some seconds, but others it just stays that way.
Other times it wont show up at all in pairing screen.
I have changed the battery in the Tickr and did the reset.
I have tried closing all other apps on the phone, but it’s still the same.
The issue seems only to affect Zwift. Works fine with other apps like Wahoo and Strava on the phone.

Hello Bjorn,
If you haven’t already, could you email and give us your details?
Phone model number, OS version, game version, and all Bluetooth device info, firmware versions if possible, and when it stopped working. We are keen on ironing out these issues ASAP, especially if it’s new. This is the first report of TickrX pairing/connection problem I’ve seen.
Sorry for the troubles, and sincere thanks for your feedback.


I think the issue is with the Tickr.

I’m in contact with wahoo now.


1 Like

I’m having the same issue with my Tickr connecting with S10 running companion app. Did you find a solution?

Hi there, i am facing the exact same issue. i can pair the TickrX to my iPhone, when i start walking it s working perfectly but as soon as i start running, speed go to 0 and the avatar stop, i still have the HR.
Did anyone find a solution ?