Tickr Fit Heart Rate Monitor pairing issues with native bluetooth on Mac Mojave

@Rich_Langston and others:
Zwift resolved this ticket on our end on May 19 2020, and part of that was to make sure Zwift is in compliance with Apple’s best practices for Bluetooth implementation.

Assuming that you’re all on the latest game build. If no, please download from zwift.com/download.

We have an article on resolving MacOS bluetooth pairing issues after a game update. Please follow the steps in that article.

Would you loop back and let us know if this successfully solved the problem?


Hi Shuji - first time forum poster, and hopefully I can add some more specifics to help with further diagnosis of this issue.

I run Zwift on Mac OS Catalina (10.15.7), with a Kickr and Tickr - both most recent generation, and both paired through the companion app. I use the companion app to connect as I find the connection is more stable; likely because my Mac is usually also connected to a set of bluetooth headphones.

  • The Kickr never drops.
  • The Tickr sometimes drops, and then is unable to reconnected.
  • After it drops, I can still see the Tickr in the Zwift Companion app bluetooth device list with an error symbol next to it, however I’m unable to reconnect without restarting both the app and game

Now - I think this is an issue with Zwift struggling to reconnect to the Tickr after bluetooth dropouts (which are just a fact of life with bluetooth). Here’s my logic:

  • Sometimes I also connect the Tickr to my Garmin Forerunner 935 and/or TrainerRoad (also on my phone, running Zwift Companion and TR side by side.
  • The Tickr signal will occasionally drop for 2 or 3 seconds (maybe once an hour - just part of life with BT).
  • You can see this across all the apps/devices - Garmin 935, TrainerRoad, and Zwift all lose HR for a few seconds.
  • However, it only seems to be Zwift that can’t pick the HR back up after it reconnects. As per my note above, the Companion App can still see the Tickr - it just can’t read HR anymore.

So my thinking is that it is something to do with the reconnection process after dropped BT signal.

Just to confirm, this issue occurs irrespective of whether I am also connected to my Garmin 935 and/or TrainerRoad. I have just noticed that when using them, it is only Zwift that struggles to pick the device back up.

Happy to provide more details, and I hope this helps in diagnosing the issue!

Just found this thread. Bought a tickr about two weeks ago so that my results will show on zwiftpower. Pairing seems to be totally random, no way to tell when/if it will pair. I’ve already lost one race to this issue. Today it was on for my race, but would not connect after I restarted the app to change worlds for my cool down. This is when using a macbook pro (Catalina) and bluetooth. No issues connecting my kickr (third generation) or my favero pedals via BT.

Also no issues connecting the tickr via BT to trainerroad on my Android phone (brand new phone, latest software).

Any more ideas since the last time this post came to the top? Otherwise it seems to be a good HRM.

I had trouble with mine last week. I have now given up on the tickr entirely. Today I even had trouble with it and my Wahoo Roam computer!

I have had my tickr for a year with no issue and not it won’t pair anymore either on my Mac. It pairs with my phone with the Wahoo app and with my Wahoo GPS.

I have been frustrated with waiting for the WahooFit Heart rate monitor to connect. It sometimes connects quickly and other times keeps searching. Any solutions? I have the Mac desktop set up with Zwift and run iPad for the Companion.

My Wahoo Kickr links immediately.

I have reported to Wahoo and they suggest linking to their app and if it pairs, the problem is with Zwift and not Wahoo. That is what I have done and still am frustrate with Zwift not pairing quickly with the WahooFit.

Of course Wahoo says it is a Zwift problem, everyone says it. But I would ask them why the Kickr is linking immediately - it is transmitting the same BLE (or ANT+) signal, isn’t it?

I do not use Wahoo products, so I can’t help you, sorry. But I never had issues with pairing Polar (BLE) or Quadlock (BLE or ANT+) HRs.

I have the opposite problem, my Tickr shows up immediately in Zwift and displays a HR even though I am not wearing it at all :frowning:


I’ve had the ticker fit issue for last two years with Windows10. Usually have two pair/unpair 2 to 5 times. It pairs, then goes into NO SIGNAL. When running it pairs flawlessly with my woodway treadmill (which then broadcasts to zwift). Everything else (tacx neo, woodway, stryd) pair without issues. Really frustrating to have to reserve 10 to 15 minutes for the ticker fit before every ride.

This worked for me. Not ideal

  1. Turn off BT on the mac
  2. Turn on Bt on your phone
  3. start companion app
  4. start zwift on mac
  5. On “Pair devices” screen, slect gear button top-right.
  6. select “user swift companion”