Tacx Smart Bike Bluetooth issues, not connecting at all

Just asking if anyone has a Tacx Smart Bike, and is having, or had issues with Bluetooth, where the bike does not connect through Bluetooth, but connects in a flash on ANT+.

More of the issue: Mac Mini, Monterey, Intel based, Went to ride and no connection, I could not get the machine to pair. So I plugged in my external BT dongle, and still no connection. Popped in the ANT+ dongle, and POP connected. (proceeded to ride, and the wife decided to use the microwave, and so is goes)

I had recently reinstalled Monterey, and, obviously Zwift, so was surprised this happened. I got my ride done, and removed Zwift, and reinstalled (again) and it now works. For how long is the question.

Is this a problem with the Mac Mini, Monterey, Zwift, the bike, solar rays, bad luck? Most frustrating. And, also, no errors in the Mac logs at all referencing BT, or Zwift. Garmin support has had some helpful suggestions. I just want to ride…

Thanks for any comments from other frustrated Tacx Smart Bike owners, or people experiencing Bluetooth problems with any of the above.

One more detail: My JBL speaker would connect, but my Garmin Dual HRM strap would not, through Bluetooth. It did, like the bike, through ANT+. I do not connect the toys to my iPad that I use for Companion. I seem to have enough problems…


Probably not crazy much help, but my Neobike is rock solid on BT and Windows, and I actually never got it stable trying with various ant+ sticks…

You haven’t by any chance paired it with the MacOS or having the Tacx app open simultaneously ? - I never managed to run more than one BT connection at the time on that bike :blush:


Any firmware updates maybe via a Tacx app?

There has been two updates for my Saris H3 since getting it ~2 months ago.

Thanks for the replies. One of the first things I did was check for other devices that might have grabbed the Bluetooth connection of the bike. I have never used my iPad with it, and my iPhone doesn’t have it in the device list, and the Tacx app app wasn’t running at the time. It seemed like the Mini just wasn’t allowing the connection. It does show up in the device list in the Bluetooth applet in Control Panel, but wasn’t active. Neither was my Garmin Dual, as I said earlier. Odd as heck, and to have ANT+ connect immediately was strange too.

I have been repeatedly quizzed on the firmware version by Garmin support. Enough so that they asked for a screen cap of the app showing the version. (As if I have that much trouble reading?) They also suggested that I try to update the bike, again, and again. There is no way to hard reset the bike to wipe the firmware, not surprising I guess, but they say that if there were a problem with the firmware, the Tacx app would ‘sense’ it and automatically attempt to reload it.

There is a red led blinking behind the drive side armature disk. When connected via ANT+ there is also a blue led, leading me to believe that there ARE status lights that Tacx didn’t think were important enough to show to users. (The 2T has them visible, and a blinking red led signifies a firmware load failure. So, who knows) They so far have claimed that the lights mean ‘nothing’, and there is no document describing their function. Their support people were surprised, from what I can determine, that there were even leds at all. I had to send a video of them to support twice, and it was escalated and I’m awaiting any decision, but the app says the bike is ‘up-to-date’, and everything ‘should be fine’.

So is there a problem with Zwift app? Possibly. Is there s problem with the bike and the last firmware load? (It came from refurbishment with that version) Possibly. Is there a problem with the Mac Mini and its Bluetooth hardware? Possibly. I wish this was funnier.

Meanwhile, all I want to do is ride…



Did you get any further in solving this ?
I was wondering if you had tried installing Zwift on your iPad just to check if it can connect using Bluetooth ? - If not it’s 99% likely it’s a bike issue - I’ve run my Neobike with several variants of iPad´s ( mostly pro´s ) and it just works.


They had me do a ride with their Tacx Training App and looked at the data. They said it connected and never dropped, and said that the problems I was having were likely due, again, to the Zwift app, which I find disturbing that the app ‘hiccuped’ twice like that. Still wondering if it was the Monterey update potentially. Coming off of a total wipe and reload and have that happen was surprising. Not getting any hardware errors was interesting, however they could have been originally from a software issue.

I don’t know what happened. So far (knock on wood) it’s 1005 stable. If it starts up again, I may have to swap the Mini.

So, shorter: Did I get further on potentially solving this? Yes, I think so. Do I have a reason why it happened? Nope (Which happens way to often in the IT industry. I was amazed at how many times you just can’t put a definitive reason why something happened, you just hoped what you did stopped it from happening)

But thanks for checking back. I appreciate it. Ride on!!

Hi @Rob_C_Neo_2
Shuji at Zwift HQ here. It’s possible this is a macOS thing. Looking through your server logs over the last couple of weeks, I’m seeing you log in from a macMini and a Macbook Pro. Looks like in the past few days, you’re able to complete rides on the macMini, but not the Macbook Pro, would you confirm?

On which machine did you update the OS? When you update macOS, it resets per-app permissions to the default (restrictive) settings. It’s possible that you may have to re-allow Zwift to have access to the Bluetooth radio chipset. Would you try these steps on resolving Bluetooth issues after a macOS update?

I use the MBP to check on events, and rides, and club activity (if any), and tweak, or create workouts. I use the Mini for all rides. (I used to use a MBP, but thought the ‘pain index video effect’ was a video card failure after not getting any info on what was causing it. So I bought a Mac Mini because of a ‘feature’ on Zwift. Oh well, the Mini works much better anyway)

I approved the access to Bluetooth otherwise it wouldn’t work at all. What was happening, to recap, was the bike wouldn’t ‘latch’ after being used the prior day, and Zwift did not see it at all. Like it was not even on. That it didn’t see my Garmin Dual either was odd, and STILL saw my Bluetooth speaker was making me think it was a Zwift issue after Tacx support recommended to dump it and reinstall earlier. Prior to that I was having a Bluetooth hardware issue (I believe) and Apple ‘suggested’ that if it continued, I should reinstall macOS, which I obviously did. So having Zwift ‘fail’ after all that was really rather odd. Not finding any hardware errors was interesting. Thanks for the tip. I’ll check it out, but would it cause a non-updated macOS install to spontaneously ignore the already known BT sources?

Back when I was on Facebook I was seriously advised to change to Windows. Um, no… I’d rather use an Apple TV if I have to switch, and I’d really rather not use one of those.

Thank you, I’ll post what I find out.