Tacx Neo Smart 2 cadence issues after Zwift update


(Vernon Mc Nees Cochrane Ab) #64

To add in my 2 cents. Upgraded to 0.0.18 and now no cadence on Ant+. I have an open case with Tacx support for my Neo2


(Stefan Glas) #65

In my opinion it’s much better with 0.0.18 but it’s not ok (Bluetooth). Sometimes cadence is correct but then it switches back to a wrong cadence.


(Jon Watkins) #66

Another one here with the same issue. Cadence dropping out with NEO2 on Zwift on PC via ANT+ connection. HR & power reading properly.

I’m a bit new to all this, can I connect the NEO2 by BT & ANT+ at the same time? I.e. could I connect the cadence to the companion app via BT with power direct to PC via ANT+ and if so would the cadence then be displayed correctly on the PC?


(Jon Watkins) #67

FYI received v0.0.19 firmware from TACX via support ticket, will try it out tonight. Maybe it will be released soon…?


(Jon Watkins) #68

Update: V0.0.19 did not fix the cadence problem. Also it could not be updated via utility app on Android, only on iOS. Have requested V0.0.15

Very annoying considering cadence worked very well one week ago when NEO2 was new with V0.0.0!


(C Gibbons) #69

Hi jon i also had the same after upgrading from 0.0.00 to 0.0.18 just had a reply from support ticket and have down graded to 0.0.15 cad issue is now fixed but now have no resistance up hills and no road feel good luck everyone


(Jon Watkins) #70

Hi, thanks for the info. I just got 0.0.15 from another user so will try it. Right now all I want is cadence and erg mode for workouts, so fingers crossed this will help.

Sounds like TACX have some work to do. I’d urge everyone with issues to raise a support ticket to highlight the extent of the problem to them.


(Mark Donaldson) #71

Hi,

I have the same NEO 2 issue - Cadence working before on 0.0.15 and broken on 0.018.

I’ve contacted TACX for old update but would be grateful if anybody could point me to where I can get the 0,0,15 downgrade firmware so I can get it working again.


(Jon Watkins) #72

Just tried 0.0.15 and now I have no cadence reading at all, just 0rpm & a cadence sensor warning in the utility app. I wonder if I have a faulty unit?

I’ll be giving TACX until the end of next week to resolve this before I return the NEO and getting a Kickr! I don’t think this is good for an expensive trainer that is only a small update from the NEO1!

This is what I have discovered so far but really all I want to do is train, not be a developer!


(Valentin Zayash) #73

Same for me,
I’ve tried all Firmware versions


(Mark Donaldson) #74

Thanks for the PM feedback Jon and Ovidiu I have downgraded to 0,0,15 and my cadence is working again.

I had a Kickr 18 before I got the Neo 2 and had to send back as there was a fault with the drive belt components - was a known issue which is now resolved). It was excellent but I was unlucky and decided to go to Neo instead. I like the virtual flywheel and features on the Neo 2 and having the cadence included (when it works) is handy.

I think either Kickr or Neo have their problems and sometimes we are just unlucky.

Either way you go I hope it works for you soon.

I’m still chasing TACX on my support ticket and hope they are aware it’s affecting many units. Fingers crossed


(Godmother Fox) #75

… don’t do it … simply don’t, unless you need to find what serious problems actually are


(Jon Watkins) #76

Seems like a functional, reliable trainer is just too much to ask for, regardless of brand.

Are any of the others any good, Elite etc?


(Steve Rice) #77

I decided a couple of days ago to take a different approach. I like the Neo2 and want to actually use it. It seems that they have cadence issues and while I believe that they should be able to fix them, I was very disappointed with the hack of a fix that was pushed out at 0.0.18. (I have 30 years of embedded systems development and understand the inner workings of these systems.) The fact that 0.0.18 was pushed out with what appears limited software QA, it seems to me that Tacx is using us as their software validation team. I don’t have time for that. I purchased a Wahoo cadence sensor and will just tie that into my Zwift system and be done with the Neo2 cadence. Sure it cost me $40, but I would rather pay $40 than continue to struggle with Tacx cadence development.


(Jon Watkins) #78

I think this may be the best option Steve, I don’t really have the time to be testing this, that and the other either. I can source an inexpensive cadence sensor locally so may pick one up later today and use FW V0.0.18 which is the only version that gives me road feel.


(Rhys Carrington) #79

I updated firmware and thought everything was sorted. No problems in ‘freeride’ mode but having constant dropouts of cadence when in ERG mode. Extremely frustrating!


(Jon Watkins) #80

That’s interesting. I am only using ERG mode at the moment as I am on a training plan, I wonder if mine would work OK in freeride? That would also explain why v0.0.15 seems to be the fix for a lot of people if they are in freeride, not ERG.

Either way, my cheap halfords cadence sensor is working OK for now, but TACX just requested my NEO back for investigation due to the cadence sensor warning in the utility app when using v0.0.015.


(Rhys Carrington) #81

I’m on my 2nd Neo in a month after sending my first (Neo 1) back due to temperature issues straight out of the box so not sending this one back too! Just ordered wahoo cadence sensor on Amazon Prime! Hopefully that should sort it all whilst there’s a working software update being developed.


(Rhys Carrington) #82

Pretty poor for a £1200 trainer though!


(Jakob Dral) #83

So I have tried different things in the last few weeks, and my conclusion goes like this. If you want to train and are bored to search and test problems, go and buy a wahoo cadence sensor and an ANT+ stick for a few bucks. With this combination I have exactly zero problems! This will connect in 1-2 seconds (Apple Watch for HRM) and have no lags no disconnections or any other probs. I don’t know if the BLE problem and the cadence problem a specific Mac problem is or a BLE problem or a zwift problem or Tacx problem or maybe all this is a problem I don’t know. What I know is that I want to train and I’m bored the search for solutions daily. So this is it, and I have the .18 firmware and don’t think that I will ever upgrade to a new firmware. Please note, “never touch a running system” But this is pretty poor for trainer for 1300€. For this price it would be nice that an ANT+ stick and a cadence sensor will be a default equipment.