Tacx Neo 2T trainer no resistance


I don’t have resistance on the Tacx Neo 2T trainer when riding in Zwift.
When Tacx training app is used on the mobile device, the resistance is engaged via Power mode.

Power cable is plugged in. I tried both simulation and ERG mode. ERG mode will not engage in Zwift.

Running on MacBook Pro, macOS 10.15.4
Firmware: 0.0.34 (the latest firmware)

I tried following combinations of connections:

ANT + : TACX FE-C 63425
Bluetooth: Tacx Neo 2T 63425153

ANT +:TACX FE-C 63425, TACX PWR 63425, Powermeter 2325
Bluetooth: Tacx Neo 2T 63425153, Assioma23205L231

Power Source:
ANT +: TACX FE-C 63425, TACX PWR 63425, Powermeter 2325
Bluetooth: Tacx Neo 2T 63425153, Assioma23205L231

I have the same issue. Works fine with Tacx, but no resistance on zwift even on highest settings

Hi, i have the same issue Trainer arrived yesterday, set up, updated the firmware to latest version on the Tacx Utility App Reun the app and resistence is their, then log into zwift going up any incline and nothing lucky to get 100W up 8% incline with cadence of 80 + please help as this is somwhat frustrating

Hi @Tony_Smith_BWCC

Welcome to the forum,

Did you pair the trainer as power source and Controllable using ANT+ FE-c?

Hi Gerrie,
Yes i did

Tony; I’ve been trying to work out the issue myself. I’ve managed to get the resistance working on normal rides now and also in workout mode. Is this only happening for you in workout mode?

Hey Jon,
Many thanks for the response! i spent some time checking through my bluetooth settings on my phone tried numerous things but finnaly got it working when turned the tacx app of Zwift worked great tonight on a meet up ride all be it somewhat harder than i remember, it is either me or the new trainer going to give me some power in the legs eventually :blush: Next is try in work out mode to really test the legs.

Many thanks for your help.


1 Like

That should do it Bluetooth can only link/pair to one program and device at a time.

sorry for very late reply. It worked when I rebooted my Mac. go figure…