Resistance problem with my Flux 2 Tacx when on Zwift

Hi everyone,

Resistance is changing 1 race on 3 when I use Zwift with my Flux 2 on a Mac. Most of the time resistance didn’t change. I tried with the Tacx application and Sufferfest to see if trainer problem or Zwift problem, and other application works perfectly.

Any suggestion?

I am on ERG mode
I bought the ANT to try to solve the problem, nothing change.
Thanks!

+1. I have the same problem. Brand new Flux 2 latest FW. Everything is fine in other apps but it seems to not be that controlable when riding in zwift.

2 Likes

Did you pair it as controllable FE-C and as a power source.

Yes. It does apply some resistance but it seems to stop during a hill and then it seems to fluctuate a lot. During my last ride it began to apply resistance on downhill

1 Like

Same here, latest firmware. no resistance, either manually setting the incline or in ERG mode. no change at all.

My problem was solve by disabled bluetooth and works with ANT+ and FEC device. Contact zwift!

1 Like

thank you. I deleted and reinstalled the apps on my phone and seem to fix the problem.

1 Like

Same here, Résistance in downhill and flats Kick in while riding

Good luck

Hi had t he problem in January and solved by updating Apple TV os, zwift app and tacx firmware.
But now 5 months later it’s starting again

I solved the problem by using the ANT mode and disconnect the Bluetooth on my Mac while I use it. Works perfectly since then :wink:

Thanks for this everyone, I’ve just bought a Tacx Flux and on a long ride this morning the resistance was all over the place. I tried trainer difficulty 0 and 100 and no real difference.
On the flats it sometimes changed resistance which was debilitating and on the hills were a gamble.

I’m either going to solve it via the replies above or sell it and move onto a wahoo kicker or similar.

Thanks all
Jonny

Did you tried to use the ANT + mode? It solves all my problems!!!

I’m going to try that on my next ride. Thanks