Tacx Flux 2 Not Changing Resistance

Tech Support!! Help needed:

I just ‘upgraded’ from the Saris 2 Wheel On Smart Trainer to a direct drive Tacx Flux 2 trainer and I’ve been having issues.

I am not feeling much resistance change in the 0-5% range. It feels the same while pedaling but my speed will drop significantly when the grade increases. This is on a regular ride, not a workout, so I do not believe I am in ERG mode.

I did the Jungle Circuit the other day and going up the rope bridge on the 8% grade, the resistance kicked in like 10 seconds once I’d gone over the bridge so it was severely delayed but it did have resistance that I could really feel.

Couple of things…

a. My FTP on the wheel on was 254 and I could cruise around a flat route at 2.8-3.4 w/kg pretty easily.

b. with the Tacx I’m barely doing 2.0 w/kg and can’t get it to go much higher unless I’m sprinting pretty hard.

c. I have calibrated the trainer using the Tacx Utility App but I tried to calibrate using the Zwift App Wrench button but it just keeps saying Device Timed Out and won’t calibrate with that.

d. I have tried adjusting the Trainer Difficulty up and down from the 50%-100% and it feels the same no matter what I do.

SO… My big question is; Is this normal when going from a wheel on to a Direct Drive or am I doing something wrong? Are there settings I’m not seeing/thinking about?

I’ve seen some other posts about it being a hardware issue so I’m also going to call Garmin, but figured I’d start and see if there were any software issues folks might know about that could help.

Running Zwift on an Apple Macbook Pro Early 2015 with Catalina OS. Same computer I used with the Wheel On Saris M2 and never had an issues.

Just to clarify, you were using a Saris M2 wheel on smart trainer with Garmin pedals?

Now you’ve upgraded to a direct drive smart trainer and are still using your Garnin pedals?

Correct me where I’ve got it wrong but is your trainer paired to Zwift as controllable?

@Bob_Gorman_Splunk_65
He doesn’t mention Garmin pedals?!?

@Mike_Turner_CFF_Cycl
You should calibrate in Tacx App only and as Bob said - pairing as controllable.
I do not know anything about Flux, but search the forum - there are some more threads about issues, perhaps you can find a solution there.

Then why is he calling Garmin?

Garmin bought Tacx (I believe it was last year).

1 Like

Mike I believe so, I have read quite a few posts about the overreading of wheel on trainers and the step down in power when moving onto a direct drive trainer. Calibration, power accuracy and different manufactures all play a part with experiencing different power readings between trainers.

I only calibrate my Flux with the Utility App and not in Zwift, make sure you have warmed up the trainer first though. On the subject of the Utility App I seem to remember setting my weight or the bike weight into the App as well as this plays a part.

Also make sure you don’t have the Utility App connected at the same time as Zwift, pretty sure this messes things up.

Hi Bob. Milan is right, Tacx is now a Garmin company so all support goes through them now. No Garmin pedals and I have it setup as “Controllable” so in theory it should be changing resistance with the grade.

Thanks so much! Going to try to play around with the weight settings and do another calibration with the Utility App then turn it off. Looking into other postings as well as this seems like it isn’t just an issue for me. Thanks for your help!

1 Like

Thanks Milan! Looking at the other posts this seems to affect more than just me so I’m going to comb those and see if I can find some tips and tricks!

Found a fix that worked in another post! Basically, what I had to do was remove two files that stored previous trainer settings, reset the Zwift App so it would re-populate the folders, then sync the new trainer. Rode 40 miles and it worked perfectly!

2 Likes

Hello, how did you do this? Im having problems with my Flux 2. I used a Megan and now when I go up 5% gradient feels like 10 and I dont get any release coming down he hills either

I had to uninstall all of the Zwift apps on my devices and then reinstall them. That seemed to have cleared out the previous trainer settings and then allowed me to setup the new trainer with its own settings.