TACX FLUX S - dynamic resistance going up hills (resistance comes and goes)

Hi! My new TACX FLUX S runs a bit strange.
On flats and moderate <2% grades it seems that the resistance equals the grade in game, so it seems to work fine.
Once I hit 6% or higher grades i noticed the resistance on my trainer would let up and come back, let up and come back. My power in game was going from 3.0 w/kg to 1.5 w/kg and then back up when the resistance returned.
I have the trainer paired with the Zwift Companion app on my iphone via Bluetooth. Not sure if I am doing something wrong.
Any help would be appreciated.

Thanks!

I’ve had that behavior with Zwift and a Tacx Flux S. It was caused by an intermittent communication between the app and the trainer. On the flats it appears to be ok, as soon as you start climbing the power is all over the place, including the resistance perceived in the pedals.

Corrective was to move my antenna closer to the trainer - in my case, I’m running from a PC, two antennas (BLE and ANT+, I use TrainerRoad in parallel with Zwift sometimes). I had one antenna on a USB extension, the other not; I added a USB hub at the end of the USB cable, put both antennas there, got them closer to the trainer, and it cured it all.

Since you’re running from a phone, it’s harder to move it, but anything you can do to get it closer to the trainer will probably help.

I’m currently using Bluetooth. Would you say it’s better to use ANT+ and move the receiver right beside the trainer? I had read using ANT+ and the FE-C option with the trainer will improve things? I’ll try that tonight !

I also have the same problem. I’ve had it since I last updated my flux’s firmware I believe. It’s very frustrating. Means I can’t race or so any worth while training on it.

Sorry. I forgot to add. I’ve tried both BT on my iPhone and my Apple TV. Same problem.

Hello, i just started using Zwift a short while ago and am still trying out several connections. I have the Tacx Flux2. When directly connected my I phone with BT everything goes smooth. When i connect the trainer to the companion app and play on my laptop then the fluctuations in power uphill start, verry annoying. This morning i tried on a Nokia phone with the trainer coupled with BT and the power was even on the flat going all the way from 40 to 250 watts every second, that was worthless… When i connected the trainer to the laptop with a ANT dongle the power was nice and linear als how it should be.
Menny different ways of connecting and only a few work nicely.
Is this a trainer, network or device problem?

Hi All! I was able to completely resolve the issues stated above by doing the suggested fix. I have attached my ANT+ receiver directly to the trainer, and have a long USB cable attached to my computer. Within ZWIFT i use the FE-C option for all peripherals and have not had a single issue since! This was definitely some kind of weird Bluetooth connectivity issue with the trainer, but was easily resolved with the ANT+ dongle. Hope this helps you guys as well.

2 Likes

I still have this issue (on a Flux S) occasionally, and it’s Bluetooth-related. Since I’m running Zwift on ANT+, that part is fixed; but I run (often in parallel) TrainerRoads on Bluetooth, and the issue then appears as spurious power reductions in Erg mode, like another app is requesting a lower power than TrainerRoad and gets to talk to the trainer every few seconds. The only solution I’ve found to that one is to cycle the power to the trainer. This usually fixes it - until the next ride.

I’ve opened a case with Garmin support, apparently they already have that issue in the works.

I also have the same problem.

You want to only have your power “controllable” by one app…

If you’re using trainer road for a workout and zwift at the same time - deselect “controllable” in the zwift pairing screen. The power will still be accurately reported to zwift, but the output will be set by trainer road.

That’s great Warren.
I have a Tacx Neo2 and had to use a solution similar to yours.
For even more stability, you can download the Tacx Utility app (that’s different to their training app) and set ANT+ to OFF. It won’t show it in that Tacx app, but you’ll still be able to use ANT-FE on Zwift. You’ll get less dropouts without ANT+ and ANT-FE interfering with each other.

Thanks, but that’s not the issue in this case. I’m well aware of how to run dual apps. The issue I raised to Garmin (and they acknowledge there’s an issue) happens with a single app running over BT - the problem occurs with both Zwift and TrainerRoad (separately).

1 Like