Tacx Neo 2T is not adjusting watts with TP workout in Zwift

I have been trying to troubleshoot this issue for a week to no avail. I have had no problems with my Tacx Trainer since it arrived in December 2022. All of my rides are uploaded by my coach into zwift from Training Peaks. This past week, when moving to the next interval, my trainer is not automatically adjusting my watts, so I am riding either at too high or too low of watts.

I’ve turned the ERG mode on and off, updated zwift, updated firmware on trainer yet the problem persists.

Any suggestions? I’ve read other posts but they are older and all seem to be relevant to the zwift update of Jan 2023.

Thank you!

Hi @Wendy_Britton welcome to Zwift forums.

Shuji at Zwift HQ here. I looked at your server logs for the past several days, and noticed that today - you logged in from an iPhone before you logged in several more times from an iPad. Seems like your iPad is your preferred device, is that correct?

This is something that affects people who run the Zwift app on mobile OS platforms more than laptop / desktops, but when you’re logged in from two devices at the same time, it manifests in many weird ways. Your symptoms are one of them.

Please power off your iPhone for troubleshooting purposes and reboot your iPad. While you’re at it - power cycle your Neo 2T for good measure. When you log in from just the iPad - does ERG mode behave as expected?

This bit is important: when you’re done riding - properly log out by always save and exit (or trash and exit) your session. If you skip this step and just swipe the app into the background - the server doesn’t recognize that you affirmatively logged off.

Please give these a try, and let us know if that works?

I do prefer the iPad, ok, this is amazing information. I rode today and didn’t have any issues with the power and ERG. It’s been such a mystery to me, as it’s happened before months ago but seemed to correct itself until it resurfaced last week. My rides this week are low stakes but I definitely want to know how to resolve this asap!

I really appreciate the follow up, and troubleshooting advice. I’ll let you know how it goes tomorrow! Thanks again :+1:t2:

@shooj help!!
I just tried a TP workout and my ERG is still not catching the watts, I got a half hour in and just threw it in the trash.

I will try again in a bit but this is becoming extremely frustrating for me and my training….

I had my phone turned off and was using Zwift off the iPad. Please help me fix this!!!

You might want to upload a log file to zwiftalizer.com and see if anything shows up in the log analysis

To find your log file:



Thanks for troubleshooting and eliminating the second login from the list of suspects.

Tell me about your Training Peaks workout: is it power-based, or heartrate-based?

TP workouts are power based…

Not sure if this is what’s affecting you, but according to the docs TrainingPeaks workouts need to be based on % of FTP.


Thanks Paul, I really appreciate your input! My FTP is the same in Zwift and TP, and sometimes my workout is fine while other times my trainer wont adjust with the interval….like today, first attempt was a disaster, second try, no issues….

So I asked someone who’s more expert than I am help look at your game log files from these two rides today. At this point, we’re inclined to think the issue here is not with the workout file generated by Training Peaks.

What sticks out though, is that you had a disaster followed by success using (I assume) the same workout, is that correct?

At this point, let’s give some attention to your trainer, and that it’s working according to what Garmin/Tacx expects. Which apps of theirs do you have installed on your smartphone? Is it just the Tacx Training app, or do you also have Garmin Connect installed?

You mentioned you updated the trainer firmware, so I trust that’s done, but for thoroughness, please verify it took correctly. Here’s the instructions on Tacx’s support site.

Then - in the Tacx Training app, I’d like to have you choose one of the built-in workouts under Power > Trainer vs Power Meter.

Does ERG mode kick in as expected? If you repeat this same workout three times - is it consistently working correctly? If not - you may have an issue with your specific trainer and should contact Tacx support.

Assuming that things work correctly in the Tacx Training app - the next suspect to eliminate is a situation where Bluetooth (aka “BLE”) signal interference is the root cause. To check for this - temporarily uninstall apps on your smartphone which might be hijacking the BLE signal. This includes both Tacx Training and Garmin Connect, which remain running in the background listening for a trainer’s BLE signal to bond to.

At this point - open Zwift and try your Training Peaks workout. Is it working as expected?

Thanks so much Shuji, this makes me think…I have a Runn device on my treadmill that sits idle while I am riding…Even though I am connected to my Tacx for my ride, is it possible that the Runn device might be interfering with Bluetooth signal while I am riding?? Just a thought that popped in my head reading your latest reply…

Probably not. Bluetooth signal disruption can take several forms, but a RUNN device “competing” for Zwift’s attention when you’re in a Ride session is low on that list. I’m more concerned about other fitness apps that hijack the trainer’s Power and Control signal. Interference from those other apps don’t show up in your game logs, so we’d have no way of knowing about them on my end.

If there’s a bike computer powered up in the house (the type on your handlebars) - that would be another suspect that is invisible to Zwift.