Tacx Neo ERG not working - help!!


(Paul Hollingworth) #1

Hi all,

I have recently upgraded from Tacx Flow to Tacx neo. 

I have set up and updated firmware, ERG mode on, tried using 3 sec power and instant power readings but I am having real problems with ERG in workout mode. I can feel the change in resistance between training blocks but the trainer / zwift is not maintaining power at target watts. I am trying to maintain a steady pedal stroke, effort but the watts are jumping around +/- 50w compared to target. So much so that I  keep failing workout blocks. The watts graph down the bottom on zwift is like a zig zag. On the flow it was easy enough to keep the watts within a few watts of the target. 

Something definitely seems wrong - any advice? I have tried googling but got nowhere other than standard advice (check firmware, check ERG is on etc). 

Would be v grateful for any advice, as loving the neo apart from that.

 

(ps I have tried on ipad and apple TV - same results)

 

 


(David K) #2

Would you mind exiting Zwift completely, pairing your Tacx Neo in it’s official support app and completing a calibration? Once you’re back in Zwift, pair your Neo, but skip the calibration inside Zwift and try a ride or two. If you don’t notice an improvement, please check your Zwift Settings to ensure your Trainer Difficulty is set to 50%, then check your FTP from your user profile to ensure it’s accurate. If it isn’t, you can manually enter a new FTP, or take an FTP test.

If none of the troubleshooting helps, please let me know so I can open an email support ticket and request a few resources from you to research.

https://support.zwift.com/hc/en-us/articles/204549679-Settings-Menu

https://support.zwift.com/hc/en-us/articles/206438003-User-Profile-Age-Weight-FTP-

https://support.zwift.com/hc/en-us/articles/360000649072–How-do-I-Take-an-FTP-Test-


(Paul Hollingworth) #3

Thank you for the reply. 

It’s my understanding that the Tacx neo ‘auto calibrates’, therefore there isn’t the option to calibrate either within the tacx app or within zwift - Or have I misunderstood? (I am used to calibrating Tacx trainers as the Tacx flow needed calibrating every few rides)

yes trainer difficulty is set to 50% and I am pretty sure my FTP is accurate (and hitting the power target isn’t the problem, it’s keeping it steady - which is very difficult when the watts are so unstable). 

Just looking at a strava graph now and as an example, during a  325W effort the power went from 280 to 370 three times over around 10 seconds


(David K) #4

You’re completely right, and I’m sorry about the miscommunication. The Neo comes pre-calibrated and doesn’t allow for calibration otherwise.

Since you’re using an AppleTV, we can’t ask for log files or resources to further research. However, I’d suspect there’s likely some kind of Bluetooth Dropout occurring here. We have an article that may help you diagnose communication issues over Bluetooth and prevent inconsistent connections.

https://support.zwift.com/hc/en-us/articles/115000111566-My-Bluetooth-signal-is-Dropping


(Paul Hollingworth) #5

Hi,

I can turn off all possible sources of interference later and give it a try (I have already turned off all competing bluetooth devices, but will try turning off other wifi, TV, fans etc). 

If this doesn’t work, how do I go about sending log files for investigation ? I can login using laptop or ipad.

 

Thanks again for your help.


(Steven D) #6

Hi Paul,

If you’re using Apple TV, regrettably we cannot retrieve log files from that device platform. 

If you continue having problems with the game, I would recommend that you please submit a support ticket and one of our Zwift support team members will be happy to further troubleshoot this issue.

 


(Paul Hollingworth) #7

Just to update on this in case others are having issues. Zwift offered to help, as did tacx but the solution wasn’t obvious. I had read in some places that sporadic watts was ‘normal’ for the Neo or perhaps that the neo was ‘more accurate’ so the watts jumped around through the pedal stroke. However, I have since returned the Neo and swapped for a new Neo unit. It is now working perfectly in ERG mode straight out of the box - very easy to maintain target watts (+/- 5W). So, if you are having problems maintaining steady watts it could be a problem with your Neo - and is definitely not normal.

Loving the Neo now!