Erg mode on Zwift not working

I have a Kickr Core paired as the Controllable, a power meter as the Power Source and Cadence, and a HRM. I pair them all via ANT+ on my laptop. This has been my setup for the last 3 years but ever since last week, erg mode hasn’t worked.

For the last two weeks, when I’m in erg mode, the trainer doesn’t hit the assigned wattage and I have to manually shift gears to get close to that wattage. I used to only shift one gear between work and rest intervals and now I have to shift three gears to even get close.

I’ve performed multiple spindowns and have the option of Control with a Power Meter via ANT+ turned on in the Wahoo app. I have changed both the power source and cadence to the Kickr Core FEC but that doesn’t fix it either.

Has anyone run into similar problems in the past?

I have the same issue on a MbPro paired with BT and Tacx Neo 2T.

If I use the Tacx app I can stay on the same gear and move between 80w and 300w without problems and at any cadence I want, the trainer adjusts perfectly.

If I use Zwift in ERG mode it’s a total disaster I need to fiddle all the time with the gears and rarely manage to get the right target power

Hi @Stefano_Mosconi

Welcome to the forum

Are you sure your trainer is not still connected to the Tacx app?

Yeah, Tacx Neo 2 doesn’t support two devices connected at the same time via Bluetooth, it’s either one or the other.