ERG not working with Tacx Bushido


I’ve just purchased a Tacx Bushido and having calibrated as directed and downloaded the app and calibrated through that, I went to ride a Zwift Workout session and the ERG mode was not working - despite ERG being requested. I had to change gears to math the required watts.
Please could you let me know what I might be doing wrong, or if there is a general problem with this - and how to rectify it.
I’m using both the mobile Zwift app and Zwift on the computer.
Many thanks

I am currently having the exact same issues with my new Tacx Bushido. I cant get the ERG to work at all. Did you find any solution to your issue?


Welcome to the zwift forum.

We will need more information, Like what system you use, BT or ANT+.

Did you pair it as controllable and powersource?


Thanks for the speedy reply.

I am usingbtue companion app to pair my devices. Zwift will not locate or pair as a controllable for me. It’s a tacx bushido

Do in need to use an ant+ connection to use ERG?

What is BT?



Are you on PC, Mac , Iphone or ATV?

BT = Bluetooth (sorry I was on my bike so it was easier to type BT. LOL)


Sorry im shite with the old acronyms.

I’m using an android phone for the companion and a pc

If you are using a Pc then my first suggestion will be to get a ANT+ dongle.

Already ordered. I will contact you again if that dose not work

Thanks for you imput

1 Like

i am sure it will work.

Let us know if your problems are solved or if you have any other questions.

Hi Guys,

I have been zwfting for a month now and having the same issues. I am using a Tacx Bushido T2780 connected as controllable to a Lenovo Tab4 10 Plus (Android tablet). I can’t seem to get ERG-Mode to work, nor do I feel changes in gradient or draft effects (trainer difficulty is set to max).

Using the Tacx-App to control the trainer, the trainer works fine and I do feel all the changes in power or gradient.

Is there a way to fix this? I do feel like I am missing out on most of the fun here :frowning:

(Just for the archive)

I fixed it! Last night I check back for some firmware for the Tacx Bushido and after installing the latest version 3.1.10, it now works fine.

I hope others, having similar issues, will find this post.

See you all on Zwift!


Same thing here with my bushido. Over windows and ant+ its perfect. In windows it doesn’t reconize using BT.

I android phone app it only find it in BT, but resistence change.