Tacx Flux 2 not simulating resistance

Hi mates, my Tacx Flux 2 smart trainer is not does not simulate slopes in Zwift (simulating resistance), and works perfectly throught Tacx Training App.The. For example, on free rides +10% slope sections I can achieve and easy pedal stroke with big chainring and a low cog.

Actualized Zwift software (for Windows)
Latest firmware on Tacx App
Fully Calibrated Trainer
Trainer difficulty 100%
Rider’s and bike weights are also correct
Conected through ANT+ FE-C with all devices
Trainer disconected from Tacx Training to work only with Zwift.

Have nice rides buddys :smile: :sunny:

Are you able to try a workout in erg mode to see if zwift is able to control the trainer at ll.

if that works then we know there is no issue with zwift connecting to the trainer. It seems like you have done all the usual things people recommend so seems odd it isn’t working.

1 Like

Lots of thanks for your response, Chris.

ERG works at 85%. Wattage accuracy is not perfect and resistance simulation is not that notable. Just like a free ride. easily achivable with big chairing and low cog, at 80-90 cadence.

It doesn’t seem like zwift is controlling your trainer.

Are you able to upload a photo of your pairing screen once everything is paired?

1 Like

It probably won’t make a difference but try pairing the power source as Tacx FE-C as well, it is best to have them all the same.


Good news from here. Firstly: Trainer is fully actualized and my connection is through a CYCPLUS ANT+ USB dongle. I was concerned that’s useful to turn off my laptop’s BT to get better results. But nothing seemed to work. That’s when I read a hidden Zwift Forum post that talked about fails with CYCPLUS USB dongles on Zwift, describing exactly my issue ( forums . zwift . com/t/no-resistance-changes-from-zwift/518332/21), and pasted a link to Tacx Facx forum, where the problem is described in detail tacxfaqx . com/knowledge-base/cycplus-ant-stick/). So, the USB was the whole thing. In addition, I didn’t know I could connect to Zwift entirely with BLE connection, so I tried it like that and the problem was completely solved (controller simulated resistance and ERG worked perfectly). The only trouble was that I couldn’t connect the HR band with BLE, but that’s when the USB dongle solved it.

So, now I can use Zwift with no trouble via BT, and the acquisition of a functional USB dongle can wait (the Tacx one is so expensive onm my country!)