Gradient Tacx Flux (T2900)

Dear all,

Being a recreational triathlete who loves riding outside, my partner was so amazing as to buy me a Tacx Flux as a birthday gift. So far I’ve been using it regularly during the week: sometimes for FTP tests (now at around 287W), more often for pre-breakfast rides to improve my anatomical system’s fat burning.

During the first two months I used the Tacx riding app, because, well… it came free with the trainer. After the 60 days were past, I switched to Zwift by recommendation of a friend.

My problem: the trainer, which supposedly is able to imitate 15% gradient, doesn’t seem to reduce or increase resistance during Zwifting.

Here some details:

  • Trainer is regularly calibrated through Tacx app
  • Also connected: Viiiiva HR monitor (for Bluetooth pairing) and (think this might be important!?) my Garmin Forerunner 945 (for Training Effect measurement)
  • Typically I run Zwift on an iPad or iPhone XR
  • During training rides, ERG mode is on because I ride on Wattage
  • During ‘Free rides’ ERG mode is off (correct?)

What I do notice when I am cycling uphill, my average speed goes down, as it goes up while cycling downhill. However I am not really interested in my average speed, I am interested in utilizing the trainer’s capacity to imitate riding uphill. It really doesn’t get heavier.

Very much looking forward to some help!

Either it does not register as a “controllable” trainer, or “trainer difficulty” is set to “off”.

Care to share you device pairing screen and in-game setting?

Two probable reasons.

  1. The trainer is not paired as an FEC device. FEC is an ANT+ extension that allows the trainer to be controlled by a third party application.
  2. The trainer is in ERG mode. ERG is a mode that removes simulated control in relation to terrain. This needs to be switched off.

Also ensure that your trainer difficulty is set correctly (100%) is always the go to level!

I own a Flix and i would bet on the FEC issue. Ensure when you pair the trainer FEC is in the name of the device.

The iphone ans I pad use Bluetooth so there is no option for FEC.

@Vincent_Willem:
Make sure that your trainer is not connected to the Tacx app. I would try uninstalling tacx app just to be sure.
In the paring screen you need to pair as Power source and controllable.

You said “During training rides, ERG mode is on because I ride on Wattage” does erg mode work? As in, does it change resistance to keep you at the desired wattage during a workout?

If so it suggests zwift is controlling the trainer.

Hi B_CN,

Don’t think the difficulty was set to off. Herewith the screens.image0 image1 image2

Indeed FEC I’ve never seen appear anywhere.

So the Tacx app I’m referring to is Tacx Utility. It doesn’t pair to the device instantly when I connect the trainer, I think (because I don’t open the Tacx app on my phone, hence it’s not active). Although it might connect to the Bluetooth of my iPhone by default. Shall try and disconnect that.

So when I train on Wattage, ERG works. When it moves to a different part of the training, resistance increases. Also, shifting my gear makes a difference - when I shift to a heavier gear, I have more Watts output.

I also just found this setting in Tacx Utility and switched it off

To everyone who replied (thanks) and who might be following this: I ‘solved’ the issue by disconnecting the Garmin FR945 altogether from the Tacx Flux. Now just recording my HR with the Garmin, while Zwift is working with the Tacx to capture Watts. Annoying stuff, but this works at least.

Since Garmin provided a firmware update to the watch, in which it enables it to do structured workouts similar to Zwift, I might cancel my Zwift subscription. Only downside for the moment is that I’d have to manually put in workouts via Garmin Connect.

1 Like