Tacx flux smart t2900 problem

Hello,

Since a week or 3 I am having the problem that it’s like inpossible to ride the big ring in a race on Zwift. I’m in the B-cat. normally I’m able to keep up with the bunch and finish top 20 or so. Now when the race starts and I am riding the big ring on my bike in order to keep up with the bunch I am experiencing heavy resistance and my cadans drops to like 40-50 rpm. I have to switch back to my small front ring but then i will get dropped. Yesterday i also tested in the C-cat (in order to check if my fitness was that bad) but still the same problem. I seems like I am still in ERG-mode in a race event.

Is anyone experiencing the same problem? please help because it’s not fun to use Zwift like this anymore…

Thanks in advance,

Kind regards,

First question, are you on the latest Zwift version and are your trainer firmware up to date?

Hello Gerrie,

Thanks for your reply,

Yes i am running the latest Zwift version and the firmware is up to date (checked yesterday via tacx utility app.

Maybe reinstalling Zwift is the solution?

Also check your trainer difficulty slider if that changed.

Do you use ANT+ if so then make sure to connect as ANT+ FE-c for both power and controllable.

Gerrie,

I checked this, it didn’t changed. ANT + connected + FE-c as controllable.

For power i am using my own Rotor InPower. But i did this also before this problem accured…

Very strange. Did you try with other software to rule out the possibility that the trainer is faulty.

check your zwift weight, I know it is obvious but worth checking.

I did not test any other software yet, beause i never used other software to train. Only Zwift.

I will check my weight. But as I sad it seems I am stuck in ERG mode or somthing. the last 25 KM of yesterdag race I raced on just one gear… flat, uphill and the sprint in the end…

does ERG work if you do workouts?

Yes ERG works, I used it a couple of times de last 2 months (before never) then I went back to a lot off race events and now I have this problem… ;(

Im having a similar problem over the last week with my tacx flux. It seems when doing any workouts the resistance becomes increasingly hard over 190/200 watts. Is there any known issues with zwifts last update. When I run the tacx software the resistance and watts read fine.

Hi Clive,

did you already found a solution?

I’m using Zwift with a Tacx Flux (1st model) and having the same experience. The resistence is heavyer then before and during the race the cadans drops. Where D-cat was easy for me and I was able to follow C-cat riders. D-cat is now what C-cat was before.

Hi Roben,

This sounds so recognizable… any idea how to fix it?

I don’t know what is causing this and also don’t know how to solve this issue. I’m also searching for the solution. I am at the last version of Zwift and latest firmware is installed on the Flux

‘’ I am at the last version of Zwift and latest firmware is installed on the Flux ‘’

I am also running the last versions…

@Zwift please help me and others with this problem…?!

@Gerrie_Delport any news yet ore solution?

Thanks!

I Rob, I don’t have any of that information. I am just an admin (Watopia wayfinder) on the site.