Tacx calibration not working in Zwift

When I pair my Tacx flux smart it states that I need to perform a calibration spindown. However when I try to do this it jumps straight to the 3rd stage asking me to keep spinning at 37kph. After 20 minutes of this it has still not moved to the 4th stage. Is this normal? How long should this take? I have tried to ride on Zwift over the weekend regardless and it is clear the power numbers are not correct. I have tried to perform a training session using the erg mode which is clearly not working properly. According to the Tacx utility app everything is up to date. I have also calibrated the trainer through thus and again it says it is correct. I first noticed the problem on Saturday 11th April and it is one Monday 13th April and I have emailed all weekend and have still not got a reply. Is anyone else unable to access Zwift to correct any issues? Or shall I just quit using it?

Easter Holidays? Increased demand on support due to massively increased numbers? Give them a break mate, you’ve only been waiting 48hrs although I appreciate it must be frustrating that you can’t get the trainer to calibrate. Assume you have searched through the forum to see if anyone else has had similar issues.

2 Likes

A few people have reported the issue and the response seems to be that you ignore the Zwift calibration and use the Tacx calibration.

2 Likes

I have done the Tacx calibration which states it is correct. But the issue seems to be that when I click on the spanner icon to perform the Zwift calibration it gets stuck on stage 3 and won’t go beyond that. But when I try to ride on Zwift either as a ride or performing a training session with the erg mode the numbers are way out.

Tried searching forums etc done everything that has been suggested. The Tacx app is all up to date and calibrated. I’ve removed and re applied the Zwift app. Still the same problem. Seems to be something to do with the calibration spindown. But it means I can’t use Zwift properly. Can’t seem to find any info regarding this issue.

Hi @Will_Burgess

Welcome to Zwift.

There are many posts on the forum saying you can use the trainer app to calibrate, the calibration value is stored on the trainer not on Zwift.

5 Likes

Dont click on it… problem solved

5 Likes

Problem isn’t solved though. It is still not reading the correct power numbers. That’s the issue.

Describe the problem again when riding on Zwift, the more detail the better, include screenshots if you can.

Hi thanks. Been on Zwift for a couple of years without any issues previous to this using the same trainer. I have calibrated using the Tacx app to do this. The issue is that this does not seem to Be fixing the issue of the power numbers being out. The resistance is not changing sufficiently when encountering hills or performing workouts. Zwift is asking me to perform a calibration spindown which is not working. Their are 5 stages to perform this task and it seems to get stuck in the third stage. And after 20 minutes Of being on this part it won’t move on. I’m trying to workout if it’s a problem with my trainer or the Zwift app. I have followed their suggestions in terms of support but this has not helped me fix the problem. I have been notified that I will receive a response in 24 hours but this is not the case. Not sure what else I can do. Hence joking the forum and putting it out there.

On Saturday I decided to do the mega pretzel route. After 8 minutes or so it starts to climb but it was clear that the resistance was not working. So I quit and tried again. The same problem again. When pairing the trainer on login the spanner icon appears asking me to perform a calibration spindown. This has 5 stages. It appears to get stuck on the 3rd stage and even after 20 minutes it will not go further than this. I have tried to do this on numerous occasions over the weekend. I tried to do a hard workout using the erg mode this morning. The resistance is not correct as this workout was far to easy. After this I also tried to just ride on Zwift and the power Stays the same regardless of the effort? The Tacx trainer I am using is up to date and calibrated on the Tacx app. The problem seems to be with the calibration spindown I’m being asked to perform which won’t take me beyond the 3rd stage of this task. And thus is affecting the power/erg on the trainer.

Has anyone else experienced this problem? People are saying I should just use the Tacx calibration and ignore the icon. But that has not fixed the problem unfortunately. I have tried to follow the Zwift support but this has not helped either.

1 Like

If Zwift tell you to calibrate you can use the trainer app. Ignore the spanner icon if you use the trainer app.
sometimes trainer companies update their firmware and apps with out letting Zwift know or it take Zwift time to include the changes.

So give us a rundown on what system you use for zwift, how you pair and the latest firmware number on the trainer.

Also are you on the latest version of Zwift.

It sound like your problem is your trainer does not change resistance?

Does it change resistance in the Tacx app?

2 Likes

Hi I’ve used the trainer app to calibrate and this states it is calibrated. I’m currently looking after the kids I’ll try to get on the Tacx app later. The problem does seem to be in the resistance. If I’m doing a just ride it feels the same at 2% incline as it does at 10%. I updated the software via the Tacx app over a week ago and rode with no problems up until Saturday 11th April. This when I tried to do the mega pretzel loop and encountered the resistance problem. I quit the ride and tried again. Only to have the same problem. I tried several rides on Zwift over the weekend. All with the same problem. On some rides the watts displayed stayed the same regardless of the effort. I tried the Matt hayman Roubaix ride this morning which is meant to be a hard effort. It felt way too easy as the erg/resistance obviously isn’t working properly. I uninstalled the Zwift application on my apple iMac laptop and reinstalled it. The same problem. I’ve tried to contact support to be told someone will get back to me in 24 hrs. But this is not case. Hence why I have tried the forum. I’ve had this problem now for three days with no reply from Zwift. I’m trying to find out if others have encountered the same problems with replies from Zwift or is it just me? Other people seem to have had a similar problem and have ignored the Zwift calibration spindown and just used the Tacx calibration. However I have not been able to fix the problem by using this advice.

Sorry for the long reply. Boring reading I know!

It does change resistance but the resistance does not match the reality of the power I’m putting out. The calibration is out. But according to the Tacx app the calibration is correct. The problem seems to be the Zwift application not reading this correctly.

Thanks for the replies

1 Like

Are you comparing it to a power meter?

1 Like

No. I’ll have a look when I can and get back. I’ll also try the Tacx trading app and see how this is. Currently got a sleeping child on me though.

Thanks for the reply.

It looked like the workout you did today worked?

It look like you had problems yesterday April 11, but before that all look fine?

1 Like

Thanks. Had problems on the Saturday 11th withe resistance. Tried doing the calibration several time’s yesterday without it working. But I don’t think these upload. If the spanner application is a known problem then why do Zwift include it and ask for it to be performed? But surely if the icon comes on then it indicates a problem with the calibration.

Wonder if you have a bad calibration stored in the game. When you click the spanner icon in Zwift I think there is a delete calibration button. Might be worth giving that a go and then just use the Tacx calibration.

1 Like

That icon is always there even if you just completed a successful calibration, it is just a tool you can use to calibrate. Like the tools in your workshop they are always there even if your car is not broken.

Where did you get a message to perform a calibration?

2 Likes