TACX Bushido Bluetooth connection drops out

I have a TACX Bushido with bluetooth and the phone app with Macbook Pro all on the same Wifi Network.

All worked fine until update auto download yesterday (23/02/2016).

Now pairing seems to go fine until the Ride button is pressed to take you to the main screen and the Power appears as “–” and the bluettoth connection drops.

After a couple of attempts (switching off the app, turning bluetooth off and on) it seemed to connect and the nubers appeared ok, but 15minutes into the ride the bluetooth dropped and my avatar comes to a stop.

This happened several times so I gave up in the end and turned to traditional garming turbo training.

Hi Wayne, 

I’m very sorry to hear your unpleasant experience. However this problem should be fixed by now, can you please make sure you are running the latest version of Zwift (1.0.10145) and try it again.

Also make sure your trainer’s software is up to date too. 

Thank you

I’m having the same problem. I’ve installed the latest version of Zwift and updated the trainer. Running OS X Yosemite 10.10.5

Oh it worked fine on the Tax trainer utility and experiences no drop out.