Swift keeps freezing


(Rick Norgy) #1

Hi

 

Swift keeps freezing and showing the loading cursor and then will start again a few minutes later. This started happening a couple of weeks ago and I am unsure why. 

 

My Mac is a a 27inch Retina with 8gb ram and Radeon R9 graphics card. Even if I run on lower graphics settings I get this behaviour.

Any thoughts?


(Jon Mayfield) #2

Rick, sorry to hear that.  Is this during a ride, while “watching” another rider, or in the menu systems before you were actually on the road?  We test on a retina iMac exactly like yours and haven’t seen long pauses like that, but maybe we can recreate the scenario at ZwiftHQ.  What exact trainer were you using? Does it get worse over time, or do the pauses happen within minutes of starting?

 


(Rick Norgy) #3

Hi Jon,

Thanks for responding. It is during rides. I am using a Tacx i-Genius Smart (with the Tacx ANT dongle) and a garmin heart rate monitor.

The freezes seem to be usually within first 10 minutes or so. I forgot to mention I am also using screen mirroring to an Apple TV which freezes at same time as iMac. When it freezes I get the loading spinner rather than standard mouse pointer when in the app, if I click out to the desktop the Mac is still responsive and other apps load quickly so I am not sure the hardware is p articularly stressed.

Hope this helps.


(Chris Bantock) #4

I am having the same problem. Just started a trial but have not been able to complete a full session as it just keeps freezing - spinning wheel - then may start up 5 - 10 mins later.  

MacBook Pro (Retina, 13-inch, Late 2012)

Processor 2.5 GHz Intel Core i5

Memory: 8 GB 1600 MHz DDR3

Graphics: Intel HD Graphics 4000 1536 MB

OS X El Capitan Version 10.11.2

Any advice would be welcome! 

 


(Nick Andrews) #5

This happened to me last night. Used zwift last weekend without issue but now it freezes. started several sessions in workout mode but froze within minutes. loading spinner for several minutes at a time

running a macbook pro 15inch

2.2 GHz Intel Core i7

16 GB 1600 MHz DDR3


(Judd Ruane) #6

I am having the same problem as Chris above.

I have tried several times but have not been able to finish a ride yet.

It just keeps freezing after 5/10 mins.

Is there any update on this issue?

 

MacBook Pro (Retina, 13-inch, 2015)

Processor 2.7 GHz Intel Core i5

Memory: 8 GB 1866 MHz LPDDR3

Graphics: Intel Iris Graphics 6100

OS X El Capitan Version 10.11.2

Turbo Trainer: Tacx Vortex Smart Trainer


(Steffen Claus ZZRC) #7

Same problem for me! Freezes 2-3 times during the first couple of minutes (race and workout mode, watch mode shows no issues). After the first 3-7 minutes, no further issues arise.

Netstat shows lots and lots of open connections to an AWS instances. Is that expected behaviour?

I am using the Tacx vortex Smart with an USB Ant+ dongle and a Garmin heart-rate monitor.

Hardware specs:

  • Macbook Pro Retina Mid 2012 15 inch,

  • 8GB Ram 1600 MHz DDR3,

  • 2,3Ghz Intel Core i7,

  • Nvidia Geforce GT 650M 1024 MB,

  • Yosemite 10.10.5.

 

Would be really fine to sort out theses issues, as racing is quite impossible this way.

 

Thanks


(Ian McKellar) #8

This has happened to me over the last couple of nights. I’m using a Wahoo Kickr (with the latest firmware update) through a 2013 Macbook Pro 15" Retina display, 2.4 GHz Processor with 8GB memory, OS Mavericks. I too am routing this through an Apple TV on to the big screen. It’s annoying as hell, because it’s been pretty fine so far, the only other times I’ve seen system hangs was when there was a load of riders from the tour down under on Zwift.