Stuttering and generally really poor app experience on Apple TV 4k


I’ve just upgraded my cycling room and treated myself to an Apple TV 4K and a Samsung UHD TV to go with my KICKR.

Everything was great, until about 10 minutes into my ride when Zwift just started stuttering and could barely run. I was using 4K 60 Hz settings. So I dropped it right down to 1080p to see if that would help, but the stuttering was just as bad.

It was completely unusable. Does anyone have any troubleshooting guides for getting this working because I feel like a bit of an idiot shelling out all this money to use Zwift like this and it not working as intended.

Many thanks.

AppleTV 4K works great. Been using one for over a year.

Please describe “stuttering”.
Did you try rebooting your Apple TV?
Are you on WiFi or ethernet?

Since it is a new Apple TV, I would start by making sure the tvOS is updated. Manually verify that is running the latest version of tvOS and that there are no updates.

Also double check that you are running the latest Zwift app. Manually go into the App store and verify there are no updates.

1 Like

Stuttering = it’ll be fine for about a second then freeze for a second. Repeat until I close the app and try again. Same again.

Apple TV is up to date and I downloaded the app from the store yesterday, so it should be the latest one.

I’m on WiFi but my connection is good in the room I’m using it in. I have VIVID 300 with Virgin Media and have had no issues using my laptop and Zwift in this room.

I tried my Apple TV tonight for the first time in a couple of weeks. I have been using my laptop temporarily due to extenuating circumstances. Anyway, I did not have any issues. Zwift had auto-updated. However, when I checked the tvOS, it was out of date. I updated and tried Zwift again w/out issue.

Download the free Speedtest app and verify that your network connection is okay. Normally, I’d say run your log file through Zwiftalizer, but that’s not an option w/the AppleTV.

When you say you close the app, are you completely closing aka force quitting the app? or just exiting the app? Make sure you are force quitting the Zwift app. Also, if running the Zwift Companion app on your phone, make sure you force quit it as well.

My internet speed when measured through my phone is usually ~100 Mbps which should be more than enough to run Zwift. As mentioned I’ve been using Zwift for about 6 months on my laptop in the same room without issue. I swapped to Apple TV and a new 4K TV and now I have this problem. I guess the wireless card in the Apple TV might not be as strong, but it streams 4K movies just fine without buffer.

I’m force quitting the app by double tapping home on the Apple TV remote and swiping up to close it. I’m not running Zwift Companion app alongside it, as everything is connected through my Apple TV, this is:

  • Wahoo KICKR (with cadence sensor), and
  • HR Monitor

I’ll double check everything is up to date tonight, but it’s a fresh install from the Apple App Store so can’t be out of date. I’ll also try running my power line into the office to get a wired internet signal, but again, I have strong internet in the office so sure it cannot be a connection issue causing this.

I have the Apple TV output set to 4K HDR 60Hz. I’ve uploaded a video so you can clearly see the issues I’m experiencing:

Hi! I don’t know if this helps, but I recently upgraded from an Apple tv 4gen to a 4k, and experienced similar problems in other apps, before I tried it with Zwift.
The problem was my HDMI cable. It worked perfectly fine before, but for the 4K you need a good quality HDMI apparently. Look for something that says “high speed tested” or similar.
It solved my problem and it was not expensive.

1 Like

Thanks. I will see if I have any others lying about the house to test this one.

Check the settings on the TV as well. Sometimes they have settings that sync better, motion control for video games.

You’re probably right. It seems like people have reported stuttering issues with 4K and Apple TV, with some cables.

Why do you keep hitting the Zwift pause button? :rofl:

That does look like it could be the cable, but you said streaming 4K was fine. Maybe some interaction between the ATV at a specific setting. I would try a diff cable or two w/some different display settings.

Measuring your network speed using a wifi device isn’t measuring what you think it is.

I would recommend that, if possible, the Apple TV be hard wired to the network. Wifi will cause lags. It’s only so fast… Your physical network is so much faster than wifi.

My router isn’t near my office, so it’s not possible to wire it in. It really can not need that much bandwidth. Zwift’s on support says:

We recommend bandwidth of 3Mbps or higher, with a ping of under 50ms. Your needs may vary based on your home network traffic (it will be slowed by simultaneous video and music streaming, etc.) and your connection consistency/signal strength.

My phone runs at 150+ Mbps in the office where Zwift is. I’m pretty sure this isn’t an internet problem. This is the current speed of my phone. If there’s a way to measure this from the Apple TV, I’ll try that too.

Put a wifi signal booster between your router and your ATV.

Again, I don’t think this is a wifi issue. My 236Mbps speed with 13ms ping is plenty enough to run Zwift. Is their own support page says I only need 3Mbps with <50ms I’m pretty sure I’m well within tolerance.

1 Like

I would tend to agree with Adam, wifi issues look different. that look like hardware, it can be tv settings a cable or anything like that. Can you take your Apple TV to another tv in the house and try it there, you can select just watch so you don’t need your bike and trainer.

You can also try to move the TV closer to the router hard wire the apple TV and see if that work. that way you can eliminate the WIFI issue and focus on other solutions. (and it is cheap/easy to move the tv and apple TV)

Gotcha… frustrating. Why don’t you call Apple Support and see what they say. HDMI cables can be fussy (as stated above) but weird that the 4k movies stream fine for you. Maybe try deleting the Zwift App on the ATV and reload it as well?

Yes. There is a Speedtest app in the App store of the Apple TV :grinning: Based on your phone output, I too doubt it is wifi. Also, you mentioned being able to stream 4K movies which also makes it highly unlikely to be your wifi.

I would definitely try another HDMI cable and/or maybe with different display settings.

Deleting the app and downloading again as @Scott_Barbour mentioned is worth a try as well.

Last resort, open a ticket w/Apple.

Okay so I think I might have solved it… And it’s a weird one. Thanks for all the suggestions so far!

When I first setup my Apple TV I had my KICKR, Cadence, and HR monitor all connected to the Apple TV via Bluetooth. Along with the remote, this is four devices, and apparently it only supports three.

When I first set it up, the cadence and HR monitor were taking turns to show ‘no signal’ although the status was connected. It let me proceed to Zwift anyway and appeared to all work. This is when the problems started to occur.

I did more research last night into compatibility issues and turns out this Bluetooth limit might just have been the cause of all my problems. So, last night I used the Companion app for Cadence and it worked like a charm. I only had 40 minutes to spare, but it ran smoothly without issue.

So, looks like this could have been something to do with the connections into the Apple TV and rather than cutting one, it just went crazy…

Here’s hoping the problems are solved! Thanks again for the help.

Bizarro! But if your problem is solved, great news!

Which HRM are you using?

I’m using a Mio wrist monitor.