Stuck and alone in Watopia?

I keep checking and it says there are different courses, but every time I ride I’m in Watopia and there are only a few other riders (it shows 1300-1400 riders, but there are only 4 or so dots and a couple of names, and the closest are usually 8-20 minutes away from me). Anyone else having this issue? I don’t even ever see ghost riders. The energy of riding with other people really helps. I thought it was supposed to be London tonight-maybe I missed the London party? :frowning:

You are on an old version of Zwift.  Do you get auto-update failure messages when you try to run?  Are you out of hard drive space?  Are you running it through the normal mac launcher menu (the rocket ship icon) or some other way? 

Oh dang, I assumed it auto updates. I’ll check for an update. I’m on a Macbook Air-an older one-and run it off the mac app. I’ve never gotten a failure message and it runs great, just no one around and always stuck in Watopia. 

Great. I couldn’t get it to download, so uninstalled/deleted the Zwift app and then downloaded and it turns out the only download available is for Ipad or Iphone and I don’t have either. So now I don’t have Zwift. It would have been nice if there was something indicating that MacBook is no longer supported with the update!!! :frowning: :frowning:

Not sure what you mean by only available on iOS.   You can download Zwift from the home page (or here ), and Zwift does auto update itself.   Why it isn’t in your case, I am not sure.

Reinstalling will at least get you on the latest version, and hopefully the auto-update starts working again.   

From the Itunes site regarding the update: Compatible with iPhone, iPad, and iPod touch. No longer lists MacBook as it did in December when I downloaded and started using it. And if you go into Itunes to get the download, it lists all of the Ipads, Ipods, and Iphones it is compatible with, but no MacBooks as it did in December. No Macbook platform anymore with this update.

Further, when you download, the file type is ipa, which cannot be used on a MacBook (which is why I can’t install the download).

To make matters worse, I have a Vortex, which can’t be run with Zwift via bluetooth. So if I get an Ipad or Iphone I have to use the lightning port for the ant+ usb and would no longer be able to mirror to the TV I have set up for the trainer. That means to use Zwift with a Vortex you now must have a PC that has a video driver capable of supporting the app (I have two laptops and neither can run Zwift because they don’t have a video driver capable-I tried). Argh. 

Maybe are you saying there is a problem on the Itunes site for downloads to Mac? Is it supposed to have a file type that can run a Macbook, but Itunes is now only offering the Iphone/Ipad version? 

By the way, thank you for the link! That link words. The one on Itunes doesn’t and the version I downloaded off Itunes in December also did not do any auto updates. You made my freakin’ night :slight_smile: My month, maybe!

That would explain the confusion. We do not distribute Zwift for mac via iTunes or App Store.  The Mac and PC app are available only on our website, and from then on out they auto-update themselves (well, for most user they do).

Glad we got you back up and running.  The next update will include some new roads in Watopia so lets try to make sure that one comes down for you when the update hits.

Really can’t thank you enough! I had no idea that the app in Itunes might be different. Have a (virtual) beer and pizza on me :wink:

Just replying since I had the same issue. I’m on a MacBook Pro with the latest OS. I had pinned the zwift app to the task bar. Then I ran it from there and the auto updater never ran. After reading this I ran the app from the applications folder and the Viola! the updater ran and I was able to ride London.

So the lesson is not to pin the application to the task bar.

How come I can’t switch from watopia to London or Virginia?

That’s why there’s a calendar-one set course per day: