Straight line Map Bug going Between events or meetups [May 2021] (Long distance)

The last three one-hour rides I’ve taken on Zwift have shown up on Strava with distances of 700+ miles, 100+ miles and thousands of miles.

I think the problem is visible in the FIT file. The start of the ride has latitude and longitude very different from the rest of the file.

5/26/2021, 6:59:44 AM 40.779042 -73.965595 0.58 0 534 0.955 81 0
5/26/2021, 6:59:45 AM 40.779054 -73.965591 2.02 0 534 1.607 81 0
5/26/2021, 6:59:46 AM 40.779070 -73.965586 3.84 0 534 2.007 81 0
5/26/2021, 6:59:48 AM -21.722589 166.201348 3.33 0 608.6 1.58 87 0
5/26/2021, 6:59:49 AM -21.735852 166.183361 3.33 0 513.8 0 88 0

When a ride shows up as thousands of miles long, the Strava cropping tool is inadequate to the task. Plus, having to manually fix every ride is tedious.

I’m using Zwift on an iPad and Zwift Companion on an iPhone. This problem began three days ago and has been consistent. It happens every ride.

Based on those coordinates, it looks like you started a ride on the NYC map, then then ‘jumped’ to the France map, but that a new activity wasn’t triggered in Zwift, which is what generally happens when you change from one map to another.

What steps did you do to move from NYC to ‘France’?

1 Like

Nigel, it is happening reliably (the past four rides) although my “technique” hasn’t changed. I enter Zwift, click on Go Ride and then click on the bottom left button to take me to the group ride (I’m probably not using the right terminology. It’s a ride set up by a friend to which I’ve been invited.) A notification pops up about waiting while Zwift takes me to the world of the group ride. I’ve tried different “starting” worlds/routes and that has the effect of changing the total mileage. In other words, New York only adds 1,000 miles to my France ride, while Watopia adds 7,000 miles.

This morning I uninstalled Zwift and then re-installed (from the cloud). After my morning ride, my mileage was above 7,000.

Definitely sounds like an issue with how Zwift is handling your ‘transport’ to the Meet Up. @shooj : Is there someplace that Ken should send some information in order to get this looked into?


@Nigel_Tufnel thanks for tagging me in.

@Ken_Kress we’d like to see your local FIT files. I’ll PM you.


The distances weren’t messed up for me but this was the map view I got on Strava from Monday’s ride. I started in NYC and then went to Richmond for a meet-up.

Hi @Robbo1234biking_B_ST welcome to Zwift forums.

Question for you and @Ken_Kress: Would you go to on your computer and find the rides where this happened? Assuming that those sessions are set to Public - please send me the URL for those rides?

We’d like to see the screenshots and also get the FIT files from those rides.



It wont let me share the link but it is the activity above.

Thank you both. The Activity links are very useful.

I realized just now that the distances I see are when the ride is “imported” into Strava, which then sends my ride info to Virgin Pulse. It has a ripple effect. But you are correct, the distance on Zwift is OK, the map is not, and the data sent to Strava, et. al., is not.

I just received an email from that says, “You’ve provided us with some .fit files and a .eml file, neither of which we have to tools to access or view. If you’re wanting to provide us with something to serve as an example exhibiting the issue, would it be possible for you to send us something using a format we can actually see? I’d recommend a jpeg type of image file (e.g. a screenshot) instead.”

Are you kidding?

So let me get this straight, you provide .fit files for download, but your support team cannot read a .fit file. Elsewhere in this site, there’s advice for a website for reading .fit files … but Zwift support doesn’t know how to read a .fit file.

I am flabbergasted!

I am not sending a jpeg/screenshot of the contents (3,000+ lines) in a .fit file.

Please let me deal with someone technical.

When I look at any of the activities listed by you guys on my phone, they crash the Companion App. None of your other activities do. So I suspect your fit files are corrupt hence the messaging from Zwift you received @Ken_Kress. It does also appear to be left hand right hand situation also - perhaps ask them to send the files to Shooj?!?

A mate also has the same symptoms as you and I have the same result on when viewing his activity on ZCA. Never had a CA crash that way before so has to be related.

Dean, I hear you but …
I’ve loaded two of the files at fitfileviewer. No errors. I’ve expanded the record section and the data is visible. If I can post the screenshot, I will.
I didn’t expect Tech Support/QA at Zwift to load the files in Companion. I thought they would have internal tools for viewing Fit files … like fitfileviewer.
From my side, things are visible, easily accessed, etc., so I don’t understand the problem.


They seem to steer forum users to 3rd party tools (like Zwiftalizer) so maybe not! Good luck Ken.

Guess what? This happened today on my ride.

Warmed up on 2019 UCI Worlds Harrogate Circuit then the meetup was in France. The two activities got combined into one fit file.


@Ken_Kress @Gerrie_Delport_ODZ @Robbo1234biking_B_ST
Thanks all - we’re on it.

Sorry for the confusing email from my colleagues. The FIT files do actually help us verify what’s happening on your end, and the folks who need them have the ones you sent in.

1 Like

For some reason, the distance traveled seems to be increasing. I’m up to 9,000 miles now. Instead of a straight line from London or whereever, the route makes several turns before zeroing in on the Solomon Islands.

Just wanted to provide an update and reinforce that this is still happening.

Assume I had this same issue yesterday:

My workaround is to save my ride before going to the meetup that way Zwift split the files.

(They found a way to force me to use the save and continue function :joy:)

1 Like