Staying in hotel, nothing is connecting

Hello all, I am on day 4 of trying to get zwift to work from my hotel room. Ive had this same set up for about 1.5 years wheel on cyclops trainer and assimo power pedals. I’ve recently moved into a residence inn for 6 months for work and suddenly nothing will connect via blue tooth on my windows machine. sometimes the trainer connects sometimes not, pedals hardly connect, I tried putting the app on my phone, sometimes the pedals connect on the app, the trainer wont connect, I’ve deleted the app and I am back to wondering why nothing will connect to windows laptop. I’ve selected all the settings files etc. I’ve tried calling and emailing zwift to no avail because the phone just hangs up on me. before I cancel this service anyone have any ideas?

If the issue is that you can’t connect to your laptop, and this same setup has worked in other locations, I would guess that your new surroundings have some sort of signal interference that was not present in your previous location. If the issue is that you can’t connect to Zwift I would guess that the WiFi where you are has some sort of restriction on it that keeps Zwift from working.

thats what i thought too, but i can connect everything to rouvy without issue, so im kind of perplexed

@joe_Banaszek when I was first getting my new setup connected to Zwift, I noticed I could connect via BT to Bkool but not Zwift, and never got Tacx working well at all. Connection is more than just does the BT see the device. Each of these apps seems to want to move different data through the interface, some more intensely than others. It would seem logical that there would be just one form of connection and all should work. But that does not seem to be the case.

My first guess is as Nigel suggests, likely a Wifi interference issue. One quick check is to install an app like Wifi Analyzer on your phone and see what channels the hotel wifi is operating on. I am an Android guy and know Wifi Analyzer is available on the Play store, I don’t know about on iOS but I presume there is something similar if not the same app. If the wifi is strong on channels 9 - 12 it could be causing some BT interference. If that is the case, your best option is to go to ANT+. You did not say what kind of device you are running Zwift on. If it is a computer that you can put an ANT+ USB dongle into, pick up an ANSELF dongle from Amazon. Potentially also get a USB extension cable. Very likely that will solve the issue. It has for many people that have been having BT connection problems and did for me.

Another option to try is seeing if you computer can connect via BT through the Companion App thus using BT from your phone instead of the computer. I has partial success with that approach, ANT+ turns out to be rock solid.

Hotel network connections often have ports blocked allowing only for the most basic of services (e.g, web, email, etc…) You might want to try connecting over a VPN.

Your description sounds like it that you can’t reliably connect your devices to the Zwift controlling device (laptop or phone). Sounds like your computer is connecting to the Zwift servers fine. Please confirm which it is. If the computer is connecting to Zwift fine (for example you can run the app, watch another rider with good streaming video, etc.) the issue is not the hotel’s wifi port control. However a VPN is always a good test if you have a VPN service. Heck, it’s a good thing to use all the time when at a hotel, but that has nothing too do with Zwift.

Correct I was able to connect to zwift just fine. My equipment would not connect to zwift. I tried vpn and no go. What eventually ended up working is I connected my laptop to the hotel Wi-Fi then I turned on my laptops mobile hotspot and connected my phone to that mobile hotspot and then turned on the zwift companion app and connect in my gear to the zwift companion app which then spoke to Zwift and I was able to ride. An absolute pain in the back side

Very creative solution but it worked. Sounds like some kind of interference with the way your computer is running BT that does not affect the phone’s BT. At least it has you up and riding. Going to an ANT+ USB dongle solution will bypass all of that if you are going to do this for 6 months. A $15 cheap solution.