Tacx won’t connect AT ALL NOW

Brand new Tacx Flow. When first got it, connected once on iPhone. Then I assume an update pumped out from Zwift and Zwift stopped seeing Tacx at all. Switched to an android phone and magically Zwift could see it. That worked for a while. Now Zwift can’t see trainer on either phone.

To test, I opened Tacx app to see if trainer is broadcasting. It is. Then I checked Bluetooth to see if phone’s Bluetooth was seeing the trainer. It is. The only thing left is Zwift app issue.

I have read dozens of posts from the last year where people report connection issues with Zwift. This is a programming issue Zwift needs to fix. The business journals are full of stories of businesses that failed because they forgot what they were about. Zwift is about connected training. It will fail if it cannot permanently solve connection issues. Great app when it works but I’m not paying for it if it won’t connect with my equipment. You shouldn’t either.

Keep in mind Bluetooth supports one connection at a time. This is to an app or device. So make sure your Tacx isn’t connected to anything else. This is something Zwift has no control over.

2 Likes

I shut off all other possible connections to allow Zwift to connect. Zwift won’t connect. I put the phone next to trainer to test signal strength and allow Zwift to connect. Zwift won’t connect. I try it on new iPhone. Zwift won’t connect. I try it on android phone. Zwift won’t connect. I then see if the trainer will pair with the trainer’s utility app to test signal strength. Full signal. It is not the trainer.

I am following a scientific method and have eliminated everything else I can think of except the app.

Additional evidence that this is an app issue: it used to work. There was an update pushed out by Zwift recently. Not sure on timing but in last two weeks it stopped working. That is around the time the Zwift update happened.

There are legions of comments saying Zwift has connection issues. This IS a Zwift issue. They need to fix it or it will end up being like AOL, making a ton of money, forgetting what the customer wants and then being worth nothing.

Grant

Yet, right now there are over 11,500 people zwifting… so it works, just not for you. The majority of the time the connection issues are caused by the environment, signal interference, bad setup, etc.

2 Likes

Have you tried running Zwift through the Companion App?

1 Like

Hi Grant,

I also have a Tacx Smart Flow - I think it’s a great value trainer but I also have connection problems sometimes.

Sometimes it won’t connect to Zwift, sometimes it won’t connect to the Tacx app when I go to calibrate it. Because it struggles to connect to both systems, I assume it’s the trainer which is the problem - maybe its signal strength is too low.

What makes you so sure Zwift is the problem for you rather than the trainer? I feel like I got what I paid for, I just use a bit of extra patience and I’m looking to upgrade to a better model and a different brand.

Funny. After I complained yesterday, today it worked for the first time in weeks. I went into airplane mode and left cell service off and it connected. Cadence, speed and hr did not connect but trainer did.

I know lots of people use Zwift but there are dozens of forum posts with connection issues. While I might be one person having connection issues, Many of those have moderators acknowledging connection issues known to Zwift. I am definitely not the only one.

We will see if it works tomorrow. Every day is an adventure with Zwift.

1 Like

Paul,

Three reasons why I believe it is a Zwift issue.

First, it used to work. Then Zwift put out update and it didn’t work. I changed nothing.

Second, I have eliminated everything else I can think of. Two different phones, Bluetooth, distance, interference, and more. Nothing else left but Zwift.

Third, Zwift acknowledged they have issues connecting with Garmin trainers. I read through many forums and found that repeated.

I do not have any connection issues with Garmin trainer. I have full signal from trainer all the time. I can see it on the Tacx app. I see it listed as Bluetooth device.

Let me posit this as a final thought. If it is a trainer issue, Garmin and Zwift should work together to fix this. We are not the only ones with issues so it is in the best interest of both companies to fix it.

Grant

Airplane mode is a good idea, there are more recommendations for it in the forum.
FYI - I have Tacx (= Garmin) Neo, no issues at all.

In airplane mode, BT shuts down…if you are checking BT signal via phone, it is connected to your phone. I cannot connect via BT to phone and open an app and have it work.

BT is fickle. Ant+ has proven to me to be more reliable.

1 Like

My BT doesn’t shut down in airplane mode, IPhone 7. Only my cell signal goes away but I have WiFi and BT,

Android - switch to Airplane mode, switch on WiFi and BT after it. The most Android phones are configurated this way - switching everything off when activating Airplane mode.

And you MUST NOT connect your devices with phone BT - BT can establish just one connection, let Zwift do it!

If you haven’t already, I’d clear off any and all bluetooth devices so whatever device you’re running is completely clear, and not looking for other devices. Also look at clearing out the memory cache on your phone or device depending on what type you are using. Make sure your hardware is updated with the latest firmware. Double click the button on apple devices and clear all running apps, same with a Samsung, only it’s the lll key left of home. After all this I’d turn your device off, and back on. Standard Windows advice we all just love to hear. Some or all of these got me connected at some point. Best of luck, sorry if this repeats stuff you have already tried. Last thing to eliminate is the wifi in your house, Zwift has a guide on common interference problems like these, best looked at there.

Thanks Curt. Will try.

Ahhh, the issues continue. Zwift worked for 11 days straight, at least the Tacx Flow was controlled through zwift (my cadenence, speed, HR have nit worked in zwift since the first couple days). One morning I tried to ride in zwift and it would.not pair with Tacx. Since then, when it pairs, it often drops during ride. I have to restart zwift. Just did an hour and it dropped after 3 mins. When it repaired zwift had watts but would not control Tacx. Super frustrating.

After my ride, I booted up my old android to see if it would work in zwift. Wiped phone and installed zwift. DOESoes zwift work? Nope. Can’t even “see” the Tacx in zwift. I then checked the Tacx utility to see if it was broadcasting. It was full signal.

I just wish someone knew what the problem was and could solve it. On my end, all the equipment is broadcasting. The phone(s) is (are) receiving full signal. Somewhere between receipt of the signal and zwift, it gets lost.

Sorry to hear you’re still having issues connecting your Wahoo Tacx Flow to Zwift. When the Flow was first developed it broadcast ANT+. which is used by various head units and of course a dongle can be added to a PC. Later Wahoo added Bluetooth Smart which according to Wahoo is basically ANT+ protocol packaged as “low energy and enables communication with smartphones, tablets and sport watches.” https://tacx.com/product/flow-smart/

It could be that Zwift has changed their software in an update so that your Wahoo Flow BT works well with Wahoo apps but not so well with Zwift. So, my first suggestion would be to try an ANT+ dongle on a PC. You can pick up an Anself dongle for under $20 on Amazon. Other than that try to connect to Zwift through the Companion app which also uses BT but maybe supports the Wahoo format a little better.