Unable to connect Tacx Vortex to Zwift

Hi all,

Not sure if this has been discussed before, but I am having issues getting Zwift to pick up my Tacx Vortex trainer.

I am using my iPhone (iOS 14) for Zwift and after I turned on the bluetooth from the phone, Zwift searches and could not locate the trainer. It kept on searching…

The trainer does connect to the Tacx Utility and Tacx Training app without issues. I read somewhere in this forum that for bluetooth, it only allows 1 connection at 1 time, so I did disconnect it on the Tacx apps, but same issue on Zwift. Also, I have upgraded the trainer firmware as advised in Zwift to at least 3.1.7. Issue here is I am only able to upgrade it to version 3.1.22/1.1.3 from the Tacx utility app and it says that is the latest update. I can’t upgrade it to 3.1.7.

Anyone else facing the issue, please share what you have done to fix or any other suggestions?


Did you ever get this problem resolved? I’m having a similar issue.

I did get it fixed. I actually deleted the Zwift app and reinstalled it. Voila! It immediately picked up the trainer. Lol

1 Like

Tried that (delete Zwift app and reinstall) and it worked! Thanks for the tip!

Great! enjoy