Tacx Vortex Not Connecting

Hi all,

Hoping you can help a newbie here, all out of ideas! I got a Tacx vortex from a friend, all working fine.

Went to setup at home…

Hi,

trying to setup a vortex a friend gave me…

  • using Zwift app on iphone and Bluetooth
    Does not show as an option to connect, stuck searching
  • try to connect on tacx app and it works instantly
  • however, when I calibrate, no power is registered

Any ideas/suggestions greatly appreciated, going out of my mind here!

Thanks,
Ed

Hi @Ed_Fogarty

Welcome to the Forums!

I have some suggestions, so please feel free to give them a try:

  1. Try calibrating your Tacx Vortex in the Tacx app first, which should eliminate the need to calibrate it in Zwift. Once you’ve calibrated the trainer, close out the Tacx app close any other fitness apps that could potentially be stealing the signal from Zwift. Basically, Zwift typically doesn’t play nice with other apps if run on the same device, so close them all, and only use Zwift on your iPhone.

  2. Force close Zwift (as explained in this article) and then check the Bluetooth settings on your iPhone. Make sure the Tacx Vortex is showing as not connected there. If the trainer is connected prior to reaching the Zwift pairing screen, it’s like the iOS device is stealing the BLE connection before Zwift itself can establish it.

  3. Also, if you have any secondary BLE enabled devices in your environment (e.g. tablets, computers, other phones, etc…), please make sure the Tacx Vortex isn’t connecting to any of those other devices. You can toggle Bluetooth OFF on those devices just to be sure.

  4. If you’re able to get the Tacx Vortex paired at Zwift’s pairing screen, skip to the next screen and start a ride. See if you get any avatar movement and power readings in-game. Also, when you’re done trying that, please press the MENU button, END RIDE, and make sure to either save or discard your activity (your choice). Doing so should generate a proper “Log out”, which I can see on our side, and which will provide more information about how you’re pairing.

  5. You could be getting wireless signal interference, so please also work to mitigate that by following the recommendations in this article.

  6. Lastly, if you haven’t checked to update the Tacx Vortex firmware, please do so and you’ll find more information in this article.

Thanks for quick response!

On #1, this is what I have tried with no luck. Tacx app connects but there’s no power registering when trying to calibrate.

For #6 have checked firmware and all up to date too.

I’ll have a review of the other options in the morning, thanks.