New Boy, be gentle, trainer connection problems

Hi new to Zwift and wondering if anyone else had similar issues. Am using a second hand Tacx Vortex trainer on Bluetooth, started out ok, connected and completed the familiarisation ride all ok. Next day I tried to do a ride and could only get the cadence and power connections but not the controllable aspect so couldn’t make my Avatar move. Tried mucking about with Bluetooth connection on the laptop and ended up with the whole Bluetooth system screwed! Tried it on a second laptop and same thing happened! Have an Ant+ dongle on the way to see if that works, but was wondering if anybody had seen this before? Is it the turbo trainer at fault causing the issue do you reckon?
Many thanks in advance for all the superb replies…

one problem I found when I was new, is that anything that sees the bluetooth signal first can hold on to it.
make sure your iPad, or iPhone etc are also not connected.
If your training near the kitchen, make sure the microwave isn’t on, or a close 2.5G wifi?

I find that my old iMac, the BT is too old to work with my trainer, so I use a dongle na force the BT to use it. But you say it has worked?
Ive also an ANT+ done, that works fine, and seems less picky ( and can connect with more than one device)

1 Like

Thanks for the reply, I think you are right with too many devices and Bluetooth signals flying around and confusing the issue.
My Ant+ Dongle arrived today (I splurged on a proper Tacx one) and it works perfectly! Did a 40 minute ride with no issues at all.
Only problem is, with Bluetooth now screwed on my Laptop, my phone companion app won’t work when I’m riding!!!

The Zwift Companion App connects to the Zwift App over your local network, not using Bluetooth. Make sure both devices are connect to the same router.

Weird, they are both on the same network, but again there are waaaaaay too many other things on the same network too! May have to wait for the kids to go to bed before Zwifting…

Try putting the phone in Airplane mode and only enabling WiFi and see if that works.

Will give that a go, Don’t want to be the ignorant guy who won’t give a ride-on back cos the app won’t work!

3 Likes

Yes, there is setting in the companion app to turn off bluetooth, do that because you don’t need it now and you won’t need to mess around with your phones general settings. Also, many routers today have two bands, 2.4 and 5G. What I would do if re-set your home router(( unplug or turn off for a few seconds) and let your devices “find” it again and make sure your companion app is next to your device running the Zwift program or app.

Yeah it’s odd, the companion app recognises that I’m riding and shows data of previous rides etc. But it doesn’t show live data during the ride. I’m sure it’s supposed to have the live map view and buttons etc available.
When I tap on the current exercise it says “this data is not available until ride is completed” or words to that effect. Is it a setting that I haven’t set properly?

To repeat suggestion from above, when that happens to me it’s because I have companion on say the 5ghz WiFi and the Zwift app on the 2.4ghz, usually cause I was mucking around with something. They both need to be on the same Wi-Fi network…

Good luck and ride on.

That sounds like your companion app and Zwift are not running on the same WiFi. If both the device you run Zwift on and the one you run the companion on are on the same WiFi (if you are running 2.4 and 5ghz they need to be on the same band) then it should show you the map/stats/chat/etc for the ride you are in.

Well it all seems to work ok now, restarted my WiFi hub and now I have my app back working correctly!

This is incorrect.

As long as your router is setup correctly communication between the ZCA and the Zwift app should be able to happen regardless if they are on 2 different WiFi frequencies or if the device that runs the Zwift App is hard wired and the ZCA is wireless.

Both devices should be connected to the same router (which can also be incorrect since the link can happen over VLAN/Subnets).

This is incorrect, see my post above.

I am a Network Admin IRL and have done numerous test on how the ZCA connects to the Zwift App.

Client Isolation could be an issue, but without knowing ALL the ins and outs of the network setup it is difficult to point to the cause.

I disagree. I had the same issue and my Zwift program as my PC was grabbing the 2.4ghz channel and my Companion app was grabbing my 5ghz channel. That’s because I have a range extender and one device grabbed it but the other was on the router. When I reset the router they both grabbed the same channel and I haven’t had problems since.
Maybe you can offer a different explanation?

Paul,
Similar to others, . I have the most basic vanilla setup of router (single ASUS RT-AC88U, no extender, wifi for Zwift and ZCA and both ios Devices) but I do have 2 bands (2.4Ghz/5Ghz) and the router requires me to name each band differently. When I occassionally have them on different bands it doesnt work. When I change them to both use the same Band it works like a charm. Hope that helps. I was merely making a suggestion based on my own experience that has consistency solved this dilema. Im sure there are many other suggestions that would equally work depending on the complexity of the network etc.

Ride on …

Sorry, but the connection can work across WiFi frequencies and VLAN/Subnets. Just because you cannot get it to work does not mean it is no true possible. I have no issues connecting across frequencies or if one is hardwired.

You might want to change your channels on the frequencies.

Try changing your channels on the frequencies, the connection can happen easily over different frequencies, VLANs or subnets.

Just because you cannot get it to work does not mean it won’t work.

If you have a SSID for 2.4Ghz that is different from the 5Ghz you need to get both your PC and Companion App on the same SSID. If you have band sharing then the SSID should be the same and you should be ok. Either way I think you solved the problem with a router rest which allowed your devices to reconnect correctly so Ride On!

https://support.zwift.com/en_us/using-the-zwift-companion-app-Hybn8qzPr

To use the ZC app, both the device that’s running Zwift (whether PC, Mac, iOS, or Apple TV) and the mobile device running ZC need to be on the same (WiFi) network and SSID (2.4 GHz vs 5 GHz) channel. After you’ve made sure they’re on the same network and SSID channel, complete these steps:

  1. If you haven’t already, launch Zwift on the device running the program and log in.
  2. Launch the ZC app on your mobile device.
  3. Log in on the ZC app using the same credentials you use for Zwift.
  4. Launch Zwift on your main device and log in.

Incorrect again, they can be on different SSID. I have my frequencies split into 2 different SSID and I have no issues getting them to connect.

I have pointed out to Zwift Support that thie info in the link is incorrect.

Please stop spreading misinformation.