Sole F65 Treadmill (2021) pairing issues

I recently purchased a Sole F65 treadmill (2021 version) and I am unable to use it with Zwift. I am using android and windows apps. Although the F65 is shown in the pairing screen for these devices, once I start a workout the speed in Zwift will show as 0 and the avatar remains motionless, regardless of the speed of the treadmill.

I have read previous forums related to this topic but have been unable to find a suitable solution.

This is quite a common occurrence not only with type treadmill but a fair few others.

  1. Have you tried bridging via ZCA?
  2. Have you tried starting the treadmill before attempting to pair?
  3. When pairing does it flash 0mph before that disappears?
  4. Have you tried pairing cadence/HR before speed?
  5. What BT adapter version is your computer using?
  6. What phone do you have?
  1. The treadmill won’t show up in the zca (and I have treadmill disconnected from any other Bluetooth devices)
  2. Yes, I’ve tried pairing it at the start screen and after I’ve started the game. I’ve tried pairing with the treadmill before I’ve started it and with it running.
  3. Sometimes it will initially show the treadmill speed but immediately drops to 0. It will stay paired in game but just shows 0 as the speed.
  4. Yeah it’s the same issue regardless of the pairing order.
  5. Bluetooth 4.0 on my PC, Bluetooth 5.0 on my phone.
  6. My phone is a Samsung s10e.

I’ve tried pairing the treadmill with the sole app and it pairs well there. The only other solution I’ve come across is pairing it to runcline on my phone and then using that as a bridge for zwift. Although that does work for zwift, the issue is that runcline doesn’t appear to be a stable app on my phone and only works the first time after installing. So I have to uninstall and reinstall runcline everytime I want to connect the treadmill to zwift.

There are a few treadmills that will connect to other apps but Zwift doesn’t see them. The coding for Zwift has a few oddities like this.

My advice would be to use the QZ Domyos app. You can run this in a similar way to Runcline, it’ll bridge the gap between treadmill and Zwift. Plus if you use your PC you’ll get auto incline.

I’ve done other posts about the app but contact the developer Roberto Viola, he’s a great guy and will talk you through it all.

There’s a Facebook page with regards to the app.

1 Like

Thank you. I’ll give that a try

I had the same issue where the Sole Treadmill detected in Zwift with a Green Signal Bar. This wouldn’t report any speed. Occasionally I would pick up the treadmill in Zwift without the Signal Bar and this put up the message BLE APP on the treadmill and this would display active speed. After a lightbulb moment whilst driving I decided to search for the Treadmill in the PC Bluetooth App (Next to Clock). First add the Treadmill to PC and THEN add it to Zwift and it worked fine every time from there.

I had this issue! It paired with no problems using Windows 10, but when I updated to Windows 11 my Sole F80 would pair on speed 0, but as soon as I pressed start on the treadmill the connection dropped out and showed speed as 0. Took me 45 minutes to work it out, but I connected the treadmill directly to Windows (Windows, settings, bluetooth, add bluetooth device) and it worked. Connects without any problems now.

I had this issue on my bowflex - would show up in the list fine, but 0 speed. On bowflex they locked the BLE sensor behind their bowflex jrny app. In the JRNY app there was a pair with zwift option - it would basically decript the encoded BLE signal if you started the workout in JRNY first, then zwift could see it. Took me weeks to figure out