Sole Fitness F65 AC (2019)

I purchased early this month the F65 treadmill. It was already in Zwift’s compatibility list.
Unfortunately I’m not able to connect it to the app.
I’m running Zwift on iPad Pro 10.5 with IOS 13.4. I tried also on iPad Pro 12.5 with IOS 13.1 and Samsung S10 Android v10 with no success.
Anybody had the chance to make it work?
The treadmill’s BLE is up and running. I could detect it with BLE scanners. And it works correctly with their app.
Thanks in advance for your help

I had to use the companion app on my iPhone to connect our Sole F80. Then it would show on our iPad or gaming PC when all connected to our home router.

1 Like

Thank you very much.
For me it’s not clear to me how to connect using the companion app. The only switch available is to turn on BLE connections on the app. But then on zwift nothing changes.
It cannot simply find the treadmill.

I did some more analysis with a BLE Scanner.
The F65 treadmill is live and kicking. I’m afraid there is some kind of incompatibility.
Is there someone that could help me with the debug?

I’m not so skilled yet on the BLE FTMS protocol.
I will put some output here.

In the Zwift device connection screen, does it show at all or is it an empty list?

In iOS, does it show in the Bluetooth settings as a device?

Finally, make sure their own app is not running at all by killing the app on all devices. Heck, even turn off BT on all other devices than the one connecting the trainer. The trainer only connects to one device and app at a time.

1 Like

Hi Martin,
yes the Zwift device connection screen has an empty list.
no on my IOS devices I can’t find the device under the blueetoth menu. I see it only if I use a ble explorer app. on an android smartphone, I can see it under bluetooth and pair, but there are no usable services. if I install Zwift on this android smartphone I cannot see the treadmill on device connection screen.
There is no app running on the iPad, nor other devices with bluetooth on nearby. I moved out all bt devices, sensors and stuff. But unfortunately I had no success.

I tried to install and configure Kinomap on the same iPad and at the end I had success to pair the treadmill as Sole Test treadmill (bluetooth smart 4.0 interactive) not Sole F65. The app controls the treadmill (incline, speed) and reads data.
So at the end I think that Zwift is not compatible with this make and model.
Thank you for your help and hope that Zwift fixes this issue. I’m available for debugging.

It’s just weird how a more expensive model would lack this compared to cheaper models that do. Our F63 works.

One last thing I can think of is to completely shut the power of the treadmill (unplug it), then connect the power again with only your iPad nearby. Does it show? Does it make a beep after coming online (not the initial “I have power” beep)? Ours make a beep when it connects to BT and I have had issues with it being stuck with a dead connection to another device, power cycle fixed it. When it is connected to a device, it becomes completely invisible to other devices.

Yes Martin, it’s weird and I’m very upset. After every use or try I shut down completely (power plug switch off) than restart it. No changes.
It’s very strange that I made to connect from Kinomap and not from Zwift. The only point is that Kinomap recognizes the tread as Sole Test and not as Sole F65.
At this point I truly think that zwift does not really support this model.
Thank you for your support

I don’t know if this helps, but this is what it looks like in my setup in the Zwift connection screen and on my iPhone, which is running the Zwift companion app, Zwift is running on a PC.

Note that the Sole indicates on its display when it is connected via Bluetooth by showing “BLE app”. When I close/end Zwift on my PC, I hear a beep and the BLE App disappears.

Martin, your treadmill is F63-2020? maybe newer firmware?
On my F65 AC the fw is D-V 1.1
Thanks a lot

We bought it half a year ago or so, so it is definately 2019. How do I see the FW version, never checked that.

When you power it up you should see it.
Or you can soft reset by pressing and holding for 5" the stop button.
I think that yours should be model 2020.

My tests with Kinomap and Zwift
This is when kinomap connects to the treadmill

with zwift I cannot see it

if I put up my stryd fottpod, that is correctly discovered by zwift and so there are non bt issues with my ipad or whatsoever

I think is definitely a zwift problem.

During startup it says 315 VER D-V 1.0. That’s it.

version 1.0 …

I have a Sole 85, I bought this treadmill in 2019, but i guess its older version. Although on Zwift web site it shows compatible yet I can not pair it with Zwift. I can pair it with Sole App and can remotely control the treadmill with sole app. I can start and stop choose programs, increase and decrease speed and incline. It just simply won’t show up on Zwift paring screen. Can anyone help. Can we upgrade firmware on the Treadmill or some patch ?

Hi Adil,
Zwift says that is compatible, as it should be also with mine.
But it doesn’t connect and that’s all. I suppose there should be compatibility issues with specific fw versions. On Kinomap, they say that the treadmill is compatible starting form 2019. It may be also on Zwift, but the specification does not mention it.
Can you identify the model year? It could be found printed on the treadmill’s back side.

Hey, Attila I could not get the date of manufacture on the back of treadmill as you suggested, only serial number and “made in Taiwan” mentioned. I could connect it to Kinomap where it is easily recognised by the App if you choose “test treadmill” . Kinomap in this setting can control the treadmill. On looking at Sole Treadmill Web site I see newer models have a USB port and tablet holder over the screen of the treadmill. I thing all the versions not having these features are older ones. Sole must have modified the electronic package mother board or something. I was interested if we can upgrade the firmware somehow to make it work with Zwift ?

Adil, is
In the rear part of the treadmill there is a label. Mine has the following

I hope ther will be an update at least on zwift.

Hi Attila
I have F65 model 2019 too.
I can not pair the treadmill with Zwift. Have you been able to fix it?